LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux Deepin (https://www.linuxquestions.org/questions/linux-deepin-101/)
-   -   lost scanner capabilities (https://www.linuxquestions.org/questions/linux-deepin-101/lost-scanner-capabilities-4175648431/)

melody525 02-16-2019 06:53 AM

lost scanner capabilities
 
Hello everyone,
I suddenly lost scanner detection on my computer HP 15, I use linux 18.3.
Also on other Acer computer in household with windows 10.
Any suggestions?
Thanks

Corvette 02-16-2019 07:40 AM

What type of scanner is it? If it is a multifunction device, with both printing and scanning capabilities, is detecting the device at all? You could try unplugging the scanner or turning it off and on. Also, if you know its IP, try pinging it or navigating to it in your web brower; many printers/scanners provide a web interface.

melody525 02-17-2019 08:16 AM

I tried all this, I have an Epson wf-3620 (multi-function). The printing option does work but i lost scanning capabilities. I hate to remove program and reload because I had problems when I originally put Linux on, with the cups thing. thanks

ferrari 02-17-2019 04:20 PM

Does /etc/sane.d/epkowa.conf conatin a 'net' entry with the correctly assigned IP address?

ferrari 02-17-2019 04:25 PM

Also, as you mentioned you are using Deepin, check that the firewall is not blocking outgoing traffic on port 1865 (default port used for Epson network scanners)...

https://help.deepsecurity.trendmicro...-firewall.html

melody525 03-01-2019 06:47 AM

Figured it out
 
After reading my epson manual the last suggestion for network errors was, turn off firewall, it worked!!

ferrari 03-01-2019 02:25 PM

No kidding. As I already hinted at in post #5 ;)

melody525 03-02-2019 06:32 AM

firewall
 
Sorry, never seen that post.
Anyhow it's working, thank you.


All times are GMT -5. The time now is 01:20 AM.