LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin
User Name
Password
Linux Deepin This forum is for the discussion of Linux Deepin.

Notices


Reply
  Search this Thread
Old 09-26-2020, 03:47 AM   #1
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Rep: Reputation: Disabled
Headphones don't work


I have three sound outputs. When I don't have headphones plugged in, sound comes out of the speakers (Line Out), and when I plug in the headphones, the output automatically switches to the "Headphones" but sound still comes out of the speakers.

Click image for larger version

Name:	Screen Capture_dde-control-center_20200926140853.png
Views:	149
Size:	101.5 KB
ID:	34146

Is there any way I can fix this?
 
Old 09-26-2020, 04:50 AM   #2
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
possibly with hdajackretask from the alsa-tools-gui package? it might help to get some more info about your system.
 
Old 09-26-2020, 07:29 AM   #3
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
************
Attached Thumbnails
Click image for larger version

Name:	Screen Capture_deepin-deb-installer_20200926175811.png
Views:	104
Size:	21.7 KB
ID:	34153  

Last edited by ya_sg; 09-26-2020 at 12:02 PM.
 
Old 09-26-2020, 12:05 PM   #4
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cordx View Post
possibly with hdajackretask from the alsa-tools-gui package? it might help to get some more info about your system.
I got the alsa-tools-gui installed but don't really know what to do here to get the headphones work.

Click image for larger version

Name:	Screen Capture_hdajackretask_20200926223117.png
Views:	99
Size:	57.5 KB
ID:	34157
 
Old 09-26-2020, 06:04 PM   #5
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
i haven't needed to use it myself so can't offer any particular suggestion. it seems like one of those things you might just need to test some options and see if they help. from the documentation:
Quote:
All jacks (and other inputs/outputs) are shown under "Pin configuration". To override one of your jacks, click the "Override" checkbox for that pin and select the desired function.
Note: If you select a "Line out (back)" override, you should also have a "Line out (front)" override. A "Line out (Center/LFE)" override will only work with the previous two overrides, and so on.
 
Old 09-26-2020, 07:09 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,465
Blog Entries: 28

Rep: Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177
What distro are you using? If it uses Pulse Audio, in the Pulse Audio mixer (pavucontrol). It should be in the repos.

I have a feeling, though, that this may be a hardware problem, that the switch inside the audio jack to switch it off when headphones are jacked in may have failed. If software solutions don't help, you may want to look into that.
 
Old 09-27-2020, 02:11 AM   #7
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cordx View Post
i haven't needed to use it myself so can't offer any particular suggestion. it seems like one of those things you might just need to test some options and see if they help. from the documentation:
I tested all the options, but couldn't get it to work unfortunately.

Quote:
Originally Posted by frankbell View Post
What distro are you using? If it uses Pulse Audio, in the Pulse Audio mixer (pavucontrol). It should be in the repos.

I have a feeling, though, that this may be a hardware problem, that the switch inside the audio jack to switch it off when headphones are jacked in may have failed. If software solutions don't help, you may want to look into that.
I'm using Deepin OS. I tried using pavucontrol but that doesn't seem to help either. Without plugging in the headphones the output port stays on Line Out.

Click image for larger version

Name:	Screen Capture_pavucontrol_20200927122416.png
Views:	81
Size:	23.6 KB
ID:	34169

As soon as I plug in the headphones, port again switches to the Headphones but sound still comes out of the speaker.

Click image for larger version

Name:	Screen Capture_pavucontrol_20200927122437.png
Views:	51
Size:	24.9 KB
ID:	34170

Regarding the hardware issue, I'm dual booting Windows 10 with Deepin OS, and headphones work fine in the Windows. Prior to Deepin, I was in Zorin OS & Ubuntu 20.04, headphones worked fine there as well.
 
Old 09-27-2020, 07:35 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,465
Blog Entries: 28

Rep: Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177
Quote:
Regarding the hardware issue, I'm dual booting Windows 10 with Deepin OS, and headphones work fine in the Windows.
That would certainly rule out hardware.

In pavucontrol, there's a section for specific outputs and devices. After you plug in your headphones, can you manipulate or mute the volume for the speakers there?
 
Old 09-28-2020, 02:45 AM   #9
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
That would certainly rule out hardware.

In pavucontrol, there's a section for specific outputs and devices. After you plug in your headphones, can you manipulate or mute the volume for the speakers there?
Hi, after I plug in the headphones, and select the port as "Line Out (unplugged)", the sound comes out of the speakers. And I can mute the speakers, but then the sound doesn't come out of anywhere.

Click image for larger version

Name:	Screen Capture_pavucontrol_20200928130201.png
Views:	63
Size:	23.0 KB
ID:	34177

For the headphones, if I select the port as "Headphones (plugged in)", the sound still comes out of the speakers, and I can mute the option as well, but then same thing goes, sound doesn't come out of anywhere.

Click image for larger version

Name:	Screen Capture_pavucontrol_20200928131127.png
Views:	51
Size:	23.2 KB
ID:	34178
 
Old 09-29-2020, 09:48 AM   #10
ya_sg
LQ Newbie
 
Registered: Sep 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Solved: I somehow sorted out this issue. The only solution I found to fix this issue was to switch to another distribution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo bluetooth headphones vs Wired Headphones WHITE_POWER General 2 06-04-2013 03:35 PM
Kubuntu 9.04, USB-headphones don't work? annihilan Linux - Hardware 1 08-03-2009 12:26 AM
Headphones don't work unless they are present at boot time... BallsOfSteel Linux - Laptop and Netbook 2 10-11-2008 05:16 PM
Ubuntu 8.04 Headphones don't work, the published fix breaks the sound ETecoli Ubuntu 3 05-22-2008 10:48 PM
Headphones don't work in linux Tengoken Linux - Hardware 6 04-04-2008 09:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin

All times are GMT -5. The time now is 08:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration