LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin
User Name
Password
Linux Deepin This forum is for the discussion of Linux Deepin.

Notices


Reply
  Search this Thread
Old 11-27-2019, 12:39 AM   #1
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Rep: Reputation: Disabled
Almost Black Screen After Signing In


I get an almost black screen after signing into Deepin. The home screen is barely visible. If you don't take a close look, you would think you get a black screen. I have posted this question on the Deepin forum without any help so far.

How to solve this problem?

Last edited by vw98008; 11-27-2019 at 11:18 AM.
 
Old 11-27-2019, 09:38 AM   #2
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Is it visible enough to get into settings and disable compositing? If so, see if it helps. When did you install Deepin? Please post here using code tags output from the info collection script inxi:
Code:
inxi -GxxSMza
Try also:
Code:
pastebinit /var/log/Xorg.0.log
and provide here the resulting URL. If you get a file not found error, try ~/.local/share/xorg/Xorg.0.log instead. If the pastebin command itself is not found or otherwise fails, you can upload one of those files via web browser to a pastebin, e.g.:
 
Old 11-27-2019, 10:09 AM   #3
uteck
Senior Member
 
Registered: Oct 2003
Location: Elgin,IL,USA
Distribution: Ubuntu based stuff for the most part
Posts: 1,173

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Sounds like the LCD backlight is set to a minimal setting.
If you can open a terminal and read it, run xrandr and see what your display is called, for me it is eDP-1.
The try this command, replace eDP-1 with your display name:
Code:
xrandr --output eDP-1 --brightness .9
Then look in your window manager to set up a key combo to control the backlight.
 
Old 11-27-2019, 11:54 AM   #4
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
Is it visible enough to get into settings and disable compositing? If so, see if it helps. When did you install Deepin? Please post here using code tags output from the info collection script inxi:
Code:
inxi -GxxSMza
Try also:
Code:
pastebinit /var/log/Xorg.0.log
and provide here the resulting URL. If you get a file not found error, try ~/.local/share/xorg/Xorg.0.log instead. If the pastebin command itself is not found or otherwise fails, you can upload one of those files via web browser to a pastebin, e.g.:
I have to use a USB live boot to get a terminal. None of the two commands are there. I can't get the inxi installed with the live boot due to various reasons.
 
Old 11-27-2019, 11:57 AM   #5
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by uteck View Post
Sounds like the LCD backlight is set to a minimal setting.
If you can open a terminal and read it, run xrandr and see what your display is called, for me it is eDP-1.
The try this command, replace eDP-1 with your display name:
Code:
xrandr --output eDP-1 --brightness .9
Then look in your window manager to set up a key combo to control the backlight.
I don't know my Dell laptop display name. The following is the output of xrandr.

Quote:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 61.00*
800x600 61.00
 
Old 11-27-2019, 02:10 PM   #6
uteck
Senior Member
 
Registered: Oct 2003
Location: Elgin,IL,USA
Distribution: Ubuntu based stuff for the most part
Posts: 1,173

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Looks like your display is named default.
 
Old 11-27-2019, 02:30 PM   #7
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Quote:
Originally Posted by uteck View Post
Looks like your display is named default.
1024x768 plus the response OP got from xrandr probably spells use of VESA or FBDEV X driver. Neither AFAIK will provide proper names to xrandr. One of these two crude fallback drivers is apparently the cause of the subject problem. Please paste entire input and output here using code tags around the paste from:
Code:
sudo inxi -GxxSza
 
Old 11-27-2019, 02:36 PM   #8
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
1024x768 plus the response OP got from xrandr probably spells use of VESA or FBDEV X driver. Neither AFAIK will provide proper names to xrandr. One of these two crude fallback drivers is apparently the cause of the subject problem. Please paste entire input and output here using code tags around the paste from:
Code:
sudo inxi -GxxSza
Again, Deepin live boot mood doesn't come with inxi. And I can't install it under the live boot. I don't know any other Linux distros come with the command or not.

Last edited by vw98008; 11-27-2019 at 02:40 PM.
 
Old 11-27-2019, 02:48 PM   #9
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
It doesn't need to be installed, merely present.
Code:
wget https://github.com/smxi/inxi/archive/master.zip
unzip master.zip
sudo sh inxi-master/inxi -GxxSza
Should solve that problem. Output can be redirected to a file for transfer in order to copy and paste. Or, before running it, run the command named script, which will capture all screen activity to a file until script is aborted.

We will probably need to see /var/log/Xorg.0.log or /var/log/Xorg.0.log.old if they exist, or if not, ~/.local/share/xorg/Xorg.0.log or ~/.local/share/xorg/Xorg.0.log. Probably
Code:
pastebinit /mnt/var/log/Xorg.0.log
or one of the other possibles should do the job if you are able to live boot something and mount your installed systems root filesystem to /mnt/.

Last edited by mrmazda; 11-27-2019 at 02:56 PM.
 
Old 11-27-2019, 03:25 PM   #10
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
It doesn't need to be installed, merely present.
Code:
wget https://github.com/smxi/inxi/archive/master.zip
unzip master.zip
sudo sh inxi-master/inxi -GxxSza
Should solve that problem. Output can be redirected to a file for transfer in order to copy and paste. Or, before running it, run the command named script, which will capture all screen activity to a file until script is aborted.

...
Thanks very much for the info.

I run those commands without any problem for the first two. For the third one, I get the following error:

Quote:
deepin@Deepin:~/Desktop$ sudo sh inxi-master/inxi -GxxSza
inxi-master/inxi: 17: inxi-master/inxi: use: not found
inxi-master/inxi: 18: inxi-master/inxi: use: not found
inxi-master/inxi: 20: inxi-master/inxi: use: not found
inxi-master/inxi: 22: inxi-master/inxi: Syntax error: "(" unexpected
 
Old 11-27-2019, 04:46 PM   #11
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Instead of that last line, do these two instead:
Code:
cd inxi-master
./inxi -GxxSza
There must be something wrong with that script that doesn't like inxi-master/inxi.
 
Old 11-27-2019, 05:44 PM   #12
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
Instead of that last line, do these two instead:
Code:
cd inxi-master
./inxi -GxxSza
There must be something wrong with that script that doesn't like inxi-master/inxi.
Here is the output:
Code:
deepin@Deepin:~/inxi-master$ ./inxi -GxxSza
System:
  Host: Deepin Kernel: 4.15.0-29deepin-generic x86_64 bits: 64 
  compiler: gcc v: 7.3.0 
  parameters: BOOT_IMAGE=/live/vmlinuz boot=live components 
  memtest noapic noapm nodma nomce nomodeset nosmp nosplash 
  vga=normal union=overlay initrd=/live/initrd.lz 
  Desktop: Deepin 15.8 wm: Deepin-Metacity dm: LightDM 
  Distro: Deepin 15.8 base: Debian unstable 
Graphics:
  Device-1: AMD RS690M [Radeon Xpress 1200/1250/1270] vendor: Dell 
  driver: N/A bus ID: 01:05.0 chip ID: 1002:791f 
  Display: x11 server: X.Org 1.20.0 driver: ati,vesa 
  unloaded: fbdev,modesetting,radeon resolution: 1024x768~61Hz 
  Message: Unable to show advanced data. Required tool glxinfo 
  missing.
The deepin version is for the live boot, but not for the installed one which is 5.11.

Last edited by vw98008; 11-27-2019 at 11:18 PM.
 
Old 11-27-2019, 10:05 PM   #13
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Quote:
Originally Posted by vw98008 View Post
Code:
deepin@Deepin:~/inxi-master$ ./inxi -GxxSza
System:    Host: Deepin Kernel: 4.15.0-29deepin-generic x86_64 bits: 64 compiler: gcc v: 7.3.0
           parameters: BOOT_IMAGE=/live/vmlinuz boot=live components memtest noapic noapm nodma nomce nomodeset nosmp nosplash vga=normal union=overlay initrd=/live/initrd.lz
           Desktop: Deepin 15.8 wm: Deepin-Metacity dm: LightDM Distro: Deepin 15.8 base: Debian unstable
Graphics:  Device-1: AMD RS690M [Radeon Xpress 1200/1250/1270] vendor: Dell driver: N/A 
           bus ID: 01:05.0 chip ID: 1002:791f
           Display: x11 server: X.Org 1.20.0 driver: ati,vesa unloaded: fbdev,modesetting,radeon resolution: 1024x768~61Hz
           Message: Unable to show advanced data. Required tool glxinfo missing.
The deepin version is for the live boot, but not for the installed one which is 5.11.
This is confusing. All those parameters make it clear the output is from a safe mode boot. The nomodeset parameter is for troubleshooting and enabling repairs to be made, but when utilized means the output doesn't represent adequately the state of things while the problem(s) described are present. Nomodeset here explains why the video mode is only 1024x768, due to use of the VESA driver fallen back to by blocking the radeon driver. When things are as they should be, output should resemble the following from Debian 10:
Code:
$ inxi -GxxSza
System:    Host: fi965 Kernel: 4.19.0-6-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           parameters: ro BOOT_IMAGE=/vmlinuz root=LABEL=w71buster mitigations=auto
           Desktop: Trinity R14.0.7 tk: Qt 3.5.0 wm: Twin dm: startx Distro: Debian GNU/Linux 10 (buster)
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV620 PRO [Radeon HD 3470] vendor: Dell driver: radeon v: kernel
           bus ID: 01:00.0 chip ID: 1002:95c0
           Display: server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa alternate: ati resolution: 1920x1200~60Hz
           OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 4.19.0-6-amd64 LLVM 7.0.1) v: 3.3 Mesa 18.3.6 compat-v: 3.0
           direct render: Yes
Boot the installed system using the rescue or safe mode Grub menu choice, then login and do:
Code:
sudo apt update
sudo apt install firmware-amd-graphics mesa-utils
This seems like a situation caused by a firmware package not being installed. If apt does not report the firmware package was already installed, this attempt to install it should fix the problem, so go ahead and try to reboot normally.

If firmware-amd-graphics was already installed, do:
Code:
sudo pastebinit /var/log/Xorg.0.log
and report the provided URL here. If you get an error message trying this, then try:
Code:
sudo pastebinit .local/share/xorg/Xorg.0.log
If you are unable to boot the installed system in failsafe mode, we'll have to try to boot live and then create a chroot to perform the above apt actions:
Code:
# sudo mount /dev/sda2 /mnt
# sudo mount -o bind /proc /mnt/proc
# sudo mount -o bind /sys /mnt/sys
# sudo mount -o bind /dev /mnt/dev
# sudo chroot /mnt
This assumes /dev/sda2 is the root partition for your installed Deepin and will have to be changed to whatever is the correct location on sda.

BTW, when you paste command output, you should be enclosing in code tags, not quote tags, which lose the output formatting.

Last edited by mrmazda; 11-27-2019 at 10:43 PM.
 
Old 11-28-2019, 11:44 AM   #14
vw98008
Member
 
Registered: Jul 2019
Posts: 173

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
...
This assumes /dev/sda2 is the root partition for your installed Deepin and will have to be changed to whatever is the correct location on sda.
...
How can you find the root partition? The command
Code:
ls -l /dev/sd*
doesn't tell me much.

I have tried lsblk and its output is for the USB, but not the hard drive. I also tried

Code:
sudo fdisk /dev/sda
with command i and partition number 1 or 2.

I can't tell whether the output is for USB or hard drive.
 
Old 11-28-2019, 01:14 PM   #15
mrmazda
LQ Guru
 
Registered: Aug 2016
Location: SE USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 5,804
Blog Entries: 1

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Try parted -l. It should be fairly obvious which is the USB.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DKIM signing using OpenDKIM not signing all emails Matt Penfold Linux - Server 0 05-13-2018 08:45 PM
Acer A0A 110 has a black screen during boot up along with a black cursor sw3etpinay Linux - Newbie 23 12-29-2010 11:05 AM
Qmailtoaster not signing the mails with DK , even after following the tutorial MegaSpot Linux - Server 0 07-04-2009 03:04 AM
Squirrelmail shows previously visited pages after signing out kumar.craja Linux - Software 1 05-25-2007 01:35 PM
Help! Knoppix almost boots then I get a black screen. Royle Linux - General 1 07-23-2004 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin

All times are GMT -5. The time now is 02:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration