LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Containers
User Name
Password
Linux - Containers This forum is for the discussion of all topics relating to Linux containers. Docker, LXC, LXD, runC, containerd, CoreOS, Kubernetes, Mesos, rkt, and all other Linux container platforms are welcome.

Notices


Reply
  Search this Thread
Old 08-26-2019, 08:40 AM   #1
Mike_Walsh
Member
 
Registered: Jul 2017
Location: King's Lynn, UK
Distribution: Nowt but Puppies....
Posts: 364

Rep: Reputation: 158Reputation: 158
Question NetFlix issues from within chroot 'jail - browser constantly 'downloading' WideVine modules, but never plays.....


Afternoon, all.

It's not often I actually find myself needing to ask for help, but this is one area where I'm a bit hazy on the specifics. I think this is the right sub-forum, since I believe a chroot 'jail' qualifies as a 'container', no?

Specifics:-

I'm a long-term 'Puppy' user, but this one has got even the guys over at Murga-Linux stumped, so I'm asking around other fora in the hope that somebody may be able to shed some light on the matter.

We do odd things in 'Puppy-land'.....like getting nostalgic, and running years-old Puppies, just for the hell of it. I'm currently playing around with a 4-series Puppy from around 10 years ago. I also have a brace of the newest, most up-to-date Puppies currently available, but I get bored running brand-new, current, up-to-date stuff all the time...!

Much of the software in this Puppy has been upgraded, and the guy who re-mastered it has seriously upgraded the glibc, libstdc++, along with all the underlying infrastructure, etc. Several forum members are currently playing around with this thing at the moment (in its time, 4.3.1 was massively popular with the community, and still has lots of adherents even now for keeping really old boxes useful); to keep safe online, we've plumped for utilising one of the newest Pups inside a 'container', running as a chroot 'jail' (Puppies are small enough to make this an entirely feasible operation, and it's a better option for elderly hardware that may not have VT instruction sets in their CPUs). Current Firefox Quantum runs a treat like this, and everything functions perfectly.....except for one thing.

NetFlix. In fact, any DRM-controlled streaming services.

I already have the DRM checkbox enabled in 'Preferences', and the relevant items are installed into the 'gmp-widevine' directory within the profile. Yet every time you visit a DRM-type website, and attempt to acces streaming content, up comes the wee banner under the address bar, 'Firefox is installing components needed to play the audio or video on this page. Please try again later...'

It seems as though as it's not registering the fact that the WideVine modules are already there, and is starting the process from scratch every time.....yet never actually completing the task. Has anybody ever come across this before, and might it be related to the fact it's running from within a chrooted environment?

Every other type of web content is accessible as expected. Any constructive comments, suggestions, ideas, would be appreciated.

TIA.


Mike.

Last edited by Mike_Walsh; 08-26-2019 at 08:57 AM.
 
Old 08-26-2019, 09:56 AM   #2
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,852
Blog Entries: 2

Rep: Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312Reputation: 1312
Stremio https://www.stremio.com
comes to mind, don't know if it'll help but it has Netflix in there?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Chromium widevine? hitest Slackware 5 04-23-2015 03:01 PM
[SOLVED] Chroot jail or Root jail bayprince Linux - Newbie 3 07-25-2011 07:43 PM
[SOLVED] chroot jail problem: 'empty' jail MatrixS_Master Linux - Security 4 03-27-2010 06:25 AM
display php errors from within chroot jail Roosta21 Linux - Server 0 11-30-2007 10:27 AM
Perl not running backticks within chroot jail Consul Linux - Security 2 08-02-2005 05:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Containers

All times are GMT -5. The time now is 09:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration