-   Libranet (
-   -   Many problems after trying to update kde with synaptic (

Kolzene 10-17-2005 10:43 PM

Many problems after trying to update kde with synaptic
Hi everyone,

I've been searching the Internet for days now trying to figure this one out, including these forums, but so far I'm only making things worse. I'm fairly new to Linux, but am experienced in troubleshooting Windows, but I need some help on this one.

It started a few days ago when I discovered the magic of Synaptic. It was far easier to use than any other installation method I've performed so far, so I was pretty excited. I guess a little too much, because I tried installing a bunch of packages at once. This created conflicts, which I tried to solve. In the end, I got rid of xlibs, which unfortunately uninstalled virtually all of my kde files. I switched over to icewm to try and fix it, and reinstalled kde with synaptic. It would not complete because one package, xscreensavers, could not be installed. When I checked why not, it needed a few libraries like libice6, libsm6, and conflicted with xlibs. It seemed that there was no way to get this install to finish without getting rid of xlibs again, which of course only started the problem.

Finally I see that it has a problem with xlibs <4.3.0 only, and a new version was available. Ok, so I try to update xlibs. That didn't work because xlibs depends on those other packages (libice6, libsm6, etc.) and tries to install them first. They don't want to install because they need the better xlibs first. Meanwhile, xlibs is partially installed at the new version, meaning nothing works anymore. (I'm typing this in on my browser which I haven't closed yet.) I mean that I cannot load any new programs in icewm. So that I don't lose access to my browser, I've kept it open looking for solution, but I can't get synaptic or even a console to run. I know I will have to probably boot to a console, or if I'm lucky maybe gnome will still work (although I'm not so optimistic about that). From there maybe I'll have to apt-get everything, or worse yet, reinstall everything from my cds.

This actually started because I needed the new kdelibs4 so I could run Krusader, which doesn't come with Libranet 2.8.1. kdelibs4 proved very difficult to install. That xlibs seemed to be the main problem throughout the process. Does anyone have any advice on this? Something I'm missing? I'm thinking that perhaps there is a specific order I need to do things in, or something to avoid doing. :confused:

Oh right. I have tried "fixing" the broken package of the xlibs. All that does is want to uninstall it and everything dependant on it... again!

Thanks in advance!

davcefai 10-18-2005 06:43 AM

Hope this helps:

On Debian I was getting this sort of problem when trying to set up the multimedia progs. I also had similar problems with Mandrake when wanting to upgrade or remove certain packages.

The solution came through an answer on this site. By upgrading the Multimedia package I forced an install of KDE 3.4, which I wanted anyway. However I still had problems such as, if I wanted to uninstall abiword, it would have taken gnome and most of KDE with it.

Since then I have added "unstable" and "experimental" to my sources and upgraded everything. These problems have gone.

I'm not familiar with Libranet but quite possibly the situation is similar. You have dependencies going in circles because of dependencies on sources you have not configured. If so the only apparent way out is to go "cutting edge" and use the Libranet equivalent of Unstable and Experimental.

Good Luck. All I can say is that it worked for me. If you're using Synaptic then probably Libranet is a Debian based dist and the same "rules" apply.

AC97Conquerer 10-18-2005 11:29 AM

Hey, I'm kind of new at helping, but I'll try to help you out the best I can. The best thing that I can suggest is...switch to Geico. LOL j/k :p

The best thing I can suggest is that you make your sources from unstable, stable, and testing, and then try to update from there:

# Make sure you're root :]

# I'm not sure if this cat call will work right :(
cat <<EOF
deb ./

deb binary/
deb-src source/

deb stable main non-free contrib
deb-src stable main non-free contrib
deb stable/non-US main contrib non-free
deb-src stable/non-US main contrib non-free

deb unstable main non-free contrib
deb-src unstable main non-free contrib
deb unstable/non-US main contrib non-free
deb-src unstable/non-US main contrib non-free

deb testing main non-free contrib
deb-src testing main non-free contrib
deb testing/non-US main contrib non-free
deb-src testing/non-US main contrib non-free

deb stable/updates main contrib non-free
deb binary/
EOF > /etc/apt/sources.list

apt-get update
apt-get install kde

Kolzene 10-20-2005 02:58 AM

Thanks for your responses guys!

I was right in that as soon I logged out of X, I wasn't able to get back in, until last night for some reason Gnome decided to start working again, which is weird because it didn't on the weekend and I didn't do anything to fix it. :confused:

So I tried your suggestions with synaptic. It didn't seem to like the additions I made to it, "unstable", "testing", etc. I tried different combinations but it just didn't like any of them. Heck, I can't even use synaptic at all to install anything, since it automatically wants to fix the broken xlibs, thereby uninstalling 200+ packages. Apt-get didn't seem to work any better. Although I've tried many different combinations, here's my current source file (that works):


deb updates/2.8/
deb security/2.8/

deb sarge main contrib non-free 
# deb-src sarge main contrib non-free

#Debian Non-US
deb sarge/non-US main contrib non-free
# deb-src sarge/non-US main contrib non-free

#Debian security updates
deb sarge/updates main contrib non-free
deb stable/updates main contrib non-free
# deb-src sarge/updates main contrib non-free
# deb-src stable/updates main contrib non-free

# deb sarge main non-free contrib unstable
# deb sarge/non-US main contrib non-free unstable/non-US
# deb sarge testing main non-free contrib
# deb sarge/non-US testing/non-US main contrib non-free
# deb sarge binary

The last five lines are ones I tried adding, but obviously took out again to make work. I tried just adding "unstable" and such to the original lines above, but that didn't seem to help either. It kept giving me "not such directory or site" errors for everything I tried. So I guess that I'm still at a loss. :(

Thanks again!

AC97Conquerer 10-20-2005 09:47 AM

Yeah, I think some of the sources on my very own apt sources list are not there, and that's normal. When I run

apt-get update
, I get a few errors of there not being certain directories, but I just ignore them :]

marcosdumay 10-23-2005 08:00 PM

If synaptic tryes to "fix" your system automaticaly, try using aptitude. It is a curses program, so, you'll need to use it on a terminal.
When you run aptitude, add the xlibs with the key + of the numeric keyborard, and press ENTER on it to chose what version you want.

Hint: Aptitude is much more powerfull than synaptic for dealing with packages, but won't help you to manage sources.

lestoil 11-07-2005 02:13 AM

libranet update problems
your problem has been addressed and answered over at the libranet site forum at Good luck. I have been getting great guidance there. There is even a libranet online book available for each version.

All times are GMT -5. The time now is 08:00 AM.