-   Grafpup (
-   -   X don't display (stay in console mode) on my IBM A21p with Grafpup (

miguipda 02-18-2008 02:53 AM

X don't display (stay in console mode) on my IBM A21p with Grafpup

could you please give me some help regarding my X display.
If I boot on the grafpup live cd and choose the 1024*768*16 the X Display appears well and is workable.

Then I installed Grafpup with the so satified idea I have about BUT after a boot sequence (all seems ok) it stay in console mode.
Well I used the xorgwizard command and give the same selection used with the live cd boot.
I try again twice the xwin command and nothing happends. I well tried all the give resolution going to come back in cosole mode/black screen/a lot of colours (quickly escaped to save my video card).
Well, well, well...

I remember I also have some problem with the previous ubuntu installed distro and also tried the give parameters with my new grafpup. Doesn't work.

Then I am now coming to you and I hope somebody can give me help to be able to use my installed grafpup.

My pc ? Portable IBM Thinkpad A21p

The graphic card ?
ATI Rage Mobility 128 with 16MB
15.0" TFT display with 1600x1200 resolution

How can I get it to work well ?

Thanks and have a nice day,

Miguipda ;-)

Simon Bridge 02-18-2008 03:29 AM

If the boot is set up for a graphical system, then X will produce errors when it fails. If not, then you will get a text login shell without any fuss. Which happens?

From a text login, you can try just entering "startx" and see what happens.

miguipda 02-18-2008 04:27 AM


it is so true I forgot to tell that was the first command I tried.
In fact no error message I just received a prompt on console mode.

Then thinking the X don't start (by default, may be) I launched the startx command that tried and display a cross in the center of the screen but directly come back to the console mode by giving the explanation text : blablabla using xorgwizard and after that try display the X with the command xwin blablabla...
And then it becomes what I said before. X don't display.

Thanks for your help.

Have a nice day,

Miguipda ;-)

Simon Bridge 02-18-2008 05:44 AM

cat /var/log/Xorg.0.log
right after an unsuccessful startx... see what it says.

Make sure you have set a lower screen resolution (1024x768) in xorg.conf, and the sync/refresh lines are commented out.

Of course, it could be that this is X... presumably you installed a desktop? Tried looking through the ttys?

miguipda 02-19-2008 12:26 AM


yesterday I tried to see what happends with a fresh startx after a normal boot.
It doesn't give the command lines I told (xorgwizard and xwin proposition) as I said.
But it give a complete black screen.

Here is my xorg.conf to help me. I set all the colour in 16 and effectively in 1024*768.

Sincerely thanks for your help.

Have a nice day,

Miguipda ;-)

#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension

# This loads the font modules
Load "type1"
Load "freetype"

# This loads the GLX module
Load "glx"

# This loads xtrap extension, used by xrandr
Load "xtrap"


# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R7/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

FontPath "/usr/X11R7/lib/X11/fonts/misc/"
FontPath "/usr/X11R7/lib/X11/fonts/Type1/"
FontPath "/usr/X11R7/lib/X11/fonts/TTF/"


# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

Option "RandR" "on"


#everything past here is auto-generated by Puppy's Xorg Wizard...

Section "ServerLayout"
Identifier " Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "fr" #xkeymap0

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto" #mouse0protocol
Option "Device" "/dev/mouse"
#Option "Emulate3Buttons"
#Option "Emulate3Timeout" "50"
#Option "ZAxisMapping" "4 5" #scrollwheel

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5-48.5
VertRefresh 40-70
#UseModes "Modes0" #monitor0usemodes

Section "Modes"
Identifier "Modes0"

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "Dac6Bit" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "DMAForXv" # [<bool>]
#Option "ForcePCIMode" # [<bool>]
#Option "CCEPIOMode" # [<bool>]
#Option "CCENoSecurity" # [<bool>]
#Option "CCEusecTimeout" # <i>
#Option "AGPMode" # <i>
#Option "AGPSize" # <i>
#Option "RingSize" # <i>
#Option "BufferSize" # <i>
#Option "EnablePageFlip" # [<bool>]
#Option "Display" # <str>
#Option "PanelWidth" # <i>
#Option "PanelHeight" # <i>
#Option "ProgramFPRegs" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "VideoKey" # <i>
#Option "ShowCache" # [<bool>]
#Option "VGAAccess" # [<bool>]
Identifier "Card0"
Driver "ati" #card0driver
VendorName "ATI Technologies Inc"
BoardName "Rage Mobility M3 AGP 2x"
BusID "PCI:1:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
Subsection "Display"
Depth 16
Modes "1024x768"


Simon Bridge 02-19-2008 12:56 AM

You have an alder card which may not support XRandR - so don't use this, and see.
switch the card0driver to "vesa" (JIC)

cat /var/log/Xorg.0.log
Of course, it could be that this is X... presumably you installed a desktop? Tried looking through the ttys?

miguipda 02-19-2008 01:08 AM


I will see this evening.
Then this means I just need to replace "Driver "ati" #card0driver" with "Driver "vesa" #card0driver". Am I well understood ?

I don't understand what you call ttys ?
Is it the six other console habitually available from the F1 to F6 function key ? I tried it but doesn't work. But if I type mc in the console mode it display a perfect (resolution) midnight commander.

Have a nice day,

Miguipda ;-)

eagles-lair 07-01-2008 12:54 AM

Just a thought. This is something I have done when a live CD works and an install does not.

Copy the /etc/X11/Xorg.conf file from the (working) live system to the same place in the file tree of the installed version, then reboot to the installed system and see if it works.

I would suggest that you should save the non-working one in the /etc/X11 directory so you can copy it back.

All the best :)

All times are GMT -5. The time now is 04:58 AM.