-   Grafpup (
-   -   Remaster doesn't copy pkgsource.txt (

bhigham 07-07-2007 03:06 PM

Remaster doesn't copy pkgsource.txt
Hi, I am new to grafpup, and just tried downloading it the other day. I like the way it works, and decided to remaster a liveCD that has what I want on it, but found that while the remaster worked, it was unable to install packages using gpkgtool. I did some further investigation, and noticed that the pkgsource.txt file from /root/.packages/ was missing. I was able to copy the missing file for my next remaster, and that seems to have solved the problem. So, that is a workaround for the problem, but not a fix.
Doing an internet search, I was unable to find this problem mentioned, so figured I would post.

mike sumner 07-08-2007 02:33 AM

Hi bhigham, thanks for posting on this. It is a known bug but Nathan has not been able to track down the cause. More users are needed to post on this with details of what they were doing just before the pkgsource.txt file went missing. There have been one or two posts on this here and on the puppy and old grafpup forum, all by me and I have not been able to to figure any pattern as to why it disappears yet. I did notice the last time, it was just after I hit the update button. I have been doing the same as you and copying a replacement by booting from the live cd, and I now keep a copy of pkgsource.txt on my data drive so I can replace it quickly.

It may not be the actual remaster that lost it. Have you tried re-mastering after you have checked that it is there?

mike sumner 07-08-2007 02:36 AM

OOPS! double posted.

bhigham 07-08-2007 08:14 AM

Remaster doesn't copy pkgsource.txt
In the original downloaded iso, the pkgsource.txt file is present, but when remaster recreates the root folder for remaster, if you look in /tmp/root/.packages, there will be a packages.txt, but no pkgsource.txt file. There is the option to add missing files before it is written to the _sfs file, so I simply copied that file into the /tmp/root/.packages folder, and the remaster then worked fine. So, the file is simply skipped in the remaster process it would seem.

another note, the pkgsource.txt file never disappears on me(at least not yet), using grafpup 2.00, it simply is not copied to the /tmp/root/.packages folder when a remaster is done

bhigham 07-09-2007 11:32 AM

Update on Remaster doesn't copy pkgsource.txt
I just wanted to jot a quick update on what I have found with remaster.
I edited the file in /usr/sbin/ and added the line
cp /root/.packages/pkgsource.txt /tmp/root/.packages/
directly after the line
cp /root/.packages/buildvariables /tmp/root/.packages/

After doing that, the pkgsource.txt file was present in the remastered ISO, and I was able to update the packages without any trouble. I also double checked and the edited version of is present in the new ISO as well, so subsequent remasters should also work.

All times are GMT -5. The time now is 10:37 AM.