-   Grafpup (
-   -   Problem using Xine in Grafpup (

PBH 08-07-2007 03:13 PM

Problem using Xine in Grafpup
I have a problem listening to the radio with Xine. (I have not tried video or music Cds as I don't use these). One of two things happens.
1. The voice starts normally and quickly develops an echo which becomes so dis-phased so that speech becomes unintelligible.
2. The voice starts normally and runs for two or three minutes, then the programme hangs and has to be restarted when it hangs again.
I see that adjustments can be made but I do not know what to do. Can anyone put me on the right path?
Interestingly, the situation in Puppy is worse. The buffering stops at 4% and will go no further.
This machine handles radio perfectly on Windows.

disciplepup 08-07-2007 06:47 PM

Hi, could you give the url of the radio station please? Also you might like to open a terminal (I think its in Start-System-terminal or somewhere) and run gxine from it (just type gxine and press enter) and then post whatever messages you get when gxine hangs.

PBH 08-10-2007 04:33 AM

The url I usually use is The problem exists on all stations. I have tried on many occasions but there was only one error message on one occasion; Fatal error. Segmentation fault. If I load Xine via the terminal there is the following message:
(gxine:5374): Gtk- Critical ** gtk_style_detach: assertion "style->attach_count>0" failed.
I hope this makes sense to you!
One point; when I setup the sound I was offered two choices of card, Intel, which I used, and Legacy ISA, which does not exist on my machine. Patrick.

disciplepup 08-10-2007 09:40 PM

-The choice of sound card is just in case you had an ISA card, as the sound wizard does not automatically detect it, so that is normal.
-I think the GTK message has nothing to do with the problem either (gtk is the gui toolkit, so it is just to do with gxine's appearance) - do you see it as soon as you load gxine from a terminal? Can you confirm that when you load gxine from a terminal, play the radio station, and it hangs, so you kill it, you don't see any additional messages?

PBH 08-11-2007 03:35 PM

I understand about the sound card. Yes, the GTK message appears when I load Gxine. When I kill Gxine after loading in the Terminal the following appears: "sh-3.00#". It does not say it is an error message.

disciplepup 08-11-2007 07:13 PM

OK, the GTK message definitely has nothing to do with it, and sh-3.00# is not an error message, so I'm sorry, but I don't know how to help you. Check through gxine's options to see if you can find anything that looks like it might be affecting it, otherwise the easiest thing to do is probably to install Mplayer and see if it is better

Did you try asking on the Puppy forum since it didn't work at all in Puppy?

BTW That site seems to work fine for me in Grafpup 104, but I have more stuff installed than I'd care to think about, and my sound card doesn't work with recent versions of Puppy/Grafpup, so I can't check in them.

PBH 08-12-2007 03:14 PM

Problem using Xine in Grafpup.
I have not yet asked in the Puppy forum. I have had a look around and see that a number of people have had difficulties but not the same as I have had. I read somewhere that Gxine works with Sea Monkey. A plugin is required. I have located this and am about to have a go. If this fails I will try Mplayer as you suggest. The problem is I really do not understand what I am doing.
Many thanks for your efforts to sort me out.

PBH 08-13-2007 11:35 AM

Problem using Xine in Grafpup
Success! A new batch of packages have appeared for Grafpup 2.00, including a new/revised Gxine + codecs and Seamonkey + audio plugin. Installation was automatic and everything works. Others may be interested.

All times are GMT -5. The time now is 06:30 PM.