LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Grafpup
User Name
Password
Grafpup This forum is for the discussion of Grafpup Linux.

Notices


Reply
  Search this Thread
Old 06-19-2007, 06:28 PM   #1
kevin-isca
LQ Newbie
 
Registered: May 2007
Location: Devon, UK
Distribution: Grafpup, Ubuntu
Posts: 8

Rep: Reputation: 0
missing lib with inkscape


Hi

I am trying to add inkscape to grapup 2.0 dillo iso. It runs fine with the opera iso but with dilo if I try and click menu icon for inkscape nothing happens. If I try to run from terminal I get error messages about missing lib files. Following advice from similar posts I have tried adding the developer sfs but this does not seem to make any difference. I have tried copying the missing files from the opera set up but again no luck

Error messages .....

sh-3.00$ inkscape
inkscape: error while loading shared libraries: libgtkspell.so.0: cannot open shared object file: No such file or directory

Solved by copying file

sh-3.00# inkscape
inkscape: error while loading shared libraries: libaspell.so.15: cannot open shared object file: No such file or directory

Copied file but then got ....

sh-3.00# inkscape
inkscape: error while loading shared libraries: /usr/lib/libaspell.so.15: file too short
sh-3.00#

Ideas very welcome.
Thanks
 
Old 06-21-2007, 11:25 AM   #2
Nathan F
Grafpup Developer
 
Registered: Jun 2006
Location: Houston, TX
Distribution: Grafpup, Dyne::Bolic
Posts: 63

Rep: Reputation: 15
Rather than just copying the files, install the aspell and gtkspell packages from the repo. They actually should have been installed automatically assuming you installed inkscape using the package manager, but if there was a problem there please let me know.

http://grafpup.org/packages/2.0/aspell-0.60.5.tar.gz
http://grafpup.org/packages/2.0/gtkspell-2.0.11.tar.gz

Nathan
 
Old 06-24-2007, 03:12 AM   #3
kevin-isca
LQ Newbie
 
Registered: May 2007
Location: Devon, UK
Distribution: Grafpup, Ubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks.

They had been installed. I uninstalled reinstalled and everything is now working.
I am just getting my head around how dependencies are working. I have had similar missing library messages from

hydrogen: error while loading shared libraries: libFLAC++.so.5: cannot open shared object file: No such file or directory

/usr/local/apps/Graphics/Blender/blender: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

So I am guessing that the installation (all done through Package Manager) is skipping some files. Is it useful for you to know when this happens?


Cheers
Kevin
 
Old 06-25-2007, 09:45 AM   #4
Nathan F
Grafpup Developer
 
Registered: Jun 2006
Location: Houston, TX
Distribution: Grafpup, Dyne::Bolic
Posts: 63

Rep: Reputation: 15
Quote:
Is it useful for you to know when this happens?
Yes, very useful. Our package management is partially automatic and partially manual. Automatic for the end user, manual for the packager in the sense that dependencies must be entered manually into a database file right now. I do have a strategy for coping with this in the future though, which should make the whole of it much more developer friendly as well as seemless for the end user.

In the case of Blender it will need the sdl package. The missing libFLAC for Hydrogen should be provided by flac, but since I upgraded flac fairly late in the development cycle I can't remember whether or not I recompiled Hydrogen against the new libraries or not. I'll have to check on it.

Nathan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
beryl missing lib d2490n Linux - Newbie 5 05-18-2007 05:10 AM
Missing lib satimis Fedora 19 08-28-2006 03:52 PM
splashutils missing lib flying-tuxman Linux - General 2 01-08-2006 02:20 PM
Missing lib files! stonehurstX11 Mandriva 9 12-15-2003 04:09 PM
Missing lib mikedh Linux - General 2 04-25-2001 10:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Grafpup

All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration