-   Grafpup (
-   -   Hard Drive access problem from live CD (

HumilityRising 01-06-2008 12:07 AM

Hard Drive access problem from live CD
This is my first live-CD. I want to run Cinepaint for starters, and am anxious to try things out. I have a Dell Inspiron 8600 normally running XP. AFter burning the ISO and configuring a few things, I tried to get to the hard drive (NTFS) to launch Cinepaint from C:. I can cd to /dev and see hda, hda1, and others but cannot get to any of them. I presume from "/" I should be able to "cd /dev/hda1". The one time I let it save my configuration file (to hda1) it appeared to hang for maybe 10 minutes or more. I powered-down to recover. Surprisingly, the file was on the hard drive after booting to XP. Any ideas will be greatly appreciated.

jrtayloriv 01-06-2008 12:26 AM

/dev/hda & /dev/hda1 are not directories. They are "block special files" (google that term for more info) which represent a hardware device. /dev/hda is the name of the whole disk and /dev/hda1 , /dev/hda2, etc are the partitions on that disk.

What you need to do to access those partitions is mount them (don't mount /dev/hda) into a directory and then use cd to go to that directory.

First check to see if the partition you want is already mounted.

Type in:

mount | grep hda
Is the partition listed in the output? If so, it's already mounted, and the directory it lists on the right is the one you cd to.

If it's NOT listed, then you need to mount it, so first create a directory to mount the partition to:

mkdir /mnt/drivec
Then mount the partition to the newly created directory:

mount /dev/hda1 /mnt/drivec
Then cd into that directory:

cd /mnt/drivec
/mnt/drivec will contain the contents of the partition /dev/hda1 now.

Hope this helps,

HumilityRising 01-06-2008 12:53 AM

That is extremely helpful.

Take care.

carmellie 02-20-2008 07:58 PM

it didn't work for me...
I'm trying to recover files from my hard disk too. I've been downloading a lot of livecds and i read somewhere that Slax mounts your hard drive automatically so that's what I'm using right now. I found an hda directory in the mnt directory already but it doesn't seem to have anything in it.

I've been trying to recover my files because it seems I'm the PXE-E61 error. This error message is shown repeatedly when i try to boot my laptop (toshiba satellite m70, in case that helps):

For realtek rtl8139(A/B/C)/RLT8130 pci fast ethernet controller v 2.11 (001205
Pxe-e61: meadia test failure, check cable
Pxe-M0F: exiting PXE rom

Does this have anything to do with it? Is it even possible to recover my files when I have this error?

I've also tried removing and replacing the battery and the hard disk already, crossed my fingers, but it didn't work(or maybe i just did it wrong or something).

can anyone help me?

thelinuxbastard 04-13-2008 06:51 PM


Originally Posted by carmellie (Post 3064405)

For realtek rtl8139(A/B/C)/RLT8130 pci fast ethernet controller v 2.11 (001205
Pxe-e61: meadia test failure, check cable
Pxe-M0F: exiting PXE rom

can anyone help me?


I've encountered errors like this before and in most cases it is BIOS related.

Most of the time your laptop isn't loading the HDD correctly. You can go into the laptop's BIOS screen and reset all settings to default (not really familiar with the Toshiba's BIOS, so you have to wing this yourself).

If that still does not work, try taking out your HDD and putting it back. Although in some cases this has caused the original problem for laptops due to bent pins.

Also make sure that you are not trying to boot from your network. You can check your "Boot Settings" in your bios to make sure that "Boot from Network" is the last priority or if there is a way to disable trying to boot from the network completely.

Hope this helps.

disciplepup 08-04-2008 07:09 AM

BTW Grafpup does have a gui for mounting your discs. If there isn't a "Drives" icon on the desktop, it is in the menu anyway.

All times are GMT -5. The time now is 11:50 PM.