-   Gentoo (
-   -   StartX problem - intel/radeon (

gentoo 03-31-2012 09:09 AM

StartX problem - intel/radeon

I have problem with startx on gentoo.


hostname: Unknown host
xauth:  file /root/.serverauth.2593 does not exist

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0.6-gentoo x86_64 Gentoo
Current Operating System: Linux hodulak 3.0.6-gentoo #17 SMP Sat March 5 13:03:11 EDT 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 30 March 2012  02:06:15PM

Current version of pixman: 0.22.2
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 31 14:18:28 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "intel" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

There is my dmesg:
There is Xorg.0.log:
There is 10-evdev.conf:
and 50-synaptics.conf
I have laptot HP dv6-6150ec wih switchable graphics Radeon and Intel.

Can you help me,please? Thank you very much

TommyC7 04-03-2012 03:36 AM

Assuming you've followed this guide properly: and have the correct kernel configurations it requested,

Try a quick "X -configure" to see if it generates the proper Xorg file that you need.

Try emerging ati-drivers and setting your video card in /etc/make.conf to ati via "VIDEO_CARDS=<video card drivers>." I don't recall the name for ati-drivers (it might be ati), but for the open source drivers it is "radeon." If you take this route, you'll need to do an "aticonfig --initial" to initialize the correct Xorg configuration file generated by the closed source proprietary drivers.

If you do get X working with the proprietary drivers, you can use Catalyst to switch between your two video cards.

i92guboj 04-04-2012 02:51 AM

Please, check your /etc/make.conf file, specifically for the $VIDEO_DRIVERS variable, and double check that all the drivers you need are defined in there. It seems you need "radeon" and "intel". Check the Gentoo guide, since I am not sure about the concrete grammar for intel chips. You can also add "vesa" as a fallback.

Then simply using "emerge -auDvN world" should (re)compile the needed package(s), including the missing drivers. Pay attention to the use flags for mesa as well, since they will define the opengl capabilities of your system. With radeon I recommend using the gallium backend (in fact I think that nowadays you'll have no choice, but double check).

You can change the settings for the opengl modules using eselect as well, but that's for a later stage.

All times are GMT -5. The time now is 03:33 PM.