-   Gentoo (
-   -   No mouse or keyboard input after install of Ati-drivers (

origami-sheep 06-09-2012 05:49 AM

No mouse or keyboard input after install of Ati-drivers
Hi all,

After installing the proprietary drivers (radeon gets my laptop too hot that it shuts off) I am unable to use the keyboardor muse. They worked fine beforehand but now I get nothing. All I can do is jab the power button

In my Xorg.log it tells me 'module does not exist' for both synaptics and evdev.
There is no reason for this: they are both in my make.conf and worked fine when I was using radeon.



I changed my Xorg.conf to something like
Section Device
Identifier. "radeonhd"
Driver. "fglrx"
End section

on the advice of a similar forum post. I get the same problem as with the ati xorg.conf

adamk75 06-09-2012 06:40 PM

Please show us your full /var/log/Xorg.0.log file.

origami-sheep 06-10-2012 02:11 AM

Sorry I would have posted back: as a shot in the dark I rebuilt xf86-input-synaptics, xf-evdev and xf-mouse and it started working again. It may be due to the downgrade in xorg-server (fglrx requires 1.11)

i92guboj 06-11-2012 02:12 AM

That was the reason.

To be on the safe side, you need to recompile all the xf86-* packages when updating or downgrading the x server.

All times are GMT -5. The time now is 03:15 PM.