-   Gentoo (
-   -   Lirc .9 with Media Center Edition (MCE) Transceiver in kernel 3.3.4 [SOLVED] (

vik 05-09-2012 03:07 AM

Lirc .9 with Media Center Edition (MCE) Transceiver in kernel 3.3.4 [SOLVED]
Hello, I'm writing this to help out anyone who has wasted days trying to get their MCE remote or Media Center Edition Transceiver working with a newer kernel (3.3.4) and new Lirc (.9). As you may know, mceusb was once built into lirc but now it is in the mainline kernel and there's very little documentation-wise to help us figure it out. Here are the steps to get it working in the new environment (this is for Gentoo but other distros should be similar):
  • Kernel configuration. Under Device Drivers->Multimedia Support->Remote Controller adapters, select Enable IR Raw decoder for the RC6 protocol, Enable IR to LIRC bridge, and Windows Media Center Ed. eHome Infrared Transceiver. The IR to LIRC bridge is what creates our /dev/lirc0 device. NOTE: compiling in Compile Remote Controller Keymap caused the buttons to repeat as mentioned here:, under troubleshooting. If you don't have an lircrc file defined, you open a terminal, and pressing the up arrow on the remote shows you the last command you typed: you have this module enabled.
  • Install lirc. I grabbed the latest, 0.9. USE flags: transmitter (might not be needed). In etc/make.conf, add this line LIRC_DEVICES="userspace". Make sure lirc_devices_userspace use flag is set.
  • The ebuild for lirc is broken for my 64 bit system. the fix is this: export LDFLAGS_amd64=""; emerge lirc.
  • grab the proper lircd.conf file from and copy it to /etc/lirc/lircd.conf.
  • /etc/init.d/lircd start. hopefully this works; if not take a look at /etc/conf.d/lircd and make sure you have a /dev/lirc0. If not, add a line LIRCD_OPTS="-d /dev/path_to_your_device" to the file.
  • test receive. run irw and press buttons on the remote. you should see "hex code" "command" "remote". For example, if I press 2 I'll see 000000037ff07bfd 00 Two mceusb.
  • test send. irsend LIST mceusb "" to see commands. Then irsend SEND_ONCE mceusb One and you should see the led light up on the transmitter.
  • now create your lircrc file and get your media center going!

I originally tried the devinput driver but wasn't able to run irsend; I would get an error "send unsupported on hardware" or something like that.

Helpful links:,, and

i92guboj 05-10-2012 01:21 AM

Bookmarking, this might be useful in the near future. Thanks for sharing :)

All times are GMT -5. The time now is 10:33 AM.