-   Gentoo (
-   -   Gentoo install does not see /dev/sda1 (

fogpipe 05-22-2012 01:10 PM

Gentoo install does not see /dev/sda1
I plan on putting everything on that one partition for / and already have a home partition which i plan on mounting after the install.

Cfdisk sees /dev/sda1 fine. That partition is already lilsted in cfdisk as xfs. Yet when i try to mount it, i get the error "no such file or dir /dev/sda1". i have no trouble mounting that partition when booted to my vector linux install. when booted to vector the mount command lists that partition as
/dev/sda1 on /test type xfs (rw)

Help. I havent had a gentoo install in years and im looking forward to it.

im using the latest amd64 minimal iso on a dual core pentium d.

EDIT: i just booted up the install routine and the error message from mount is:"special device /dev/sda1 does not exist"

rokytnji 05-22-2012 04:24 PM

Try /dev/sda instead of /dev/sda1.

fogpipe 05-22-2012 09:53 PM

i think mount requires that a specific partition be named. i tried mounting other partitions on /dev/sda and got the same error, despite /dev/sda being listed in /dev, and specifying the file type.

syg00 05-22-2012 11:01 PM

Let's see "parted -l" (as root) from both systems. Use [code] tags when replying.

fogpipe 05-22-2012 11:45 PM


Originally Posted by syg00 (Post 4685307)
Let's see "parted -l" (as root) from both systems. Use [code] tags when replying.

Here is the output from parted when booted to vector:

[root@thor:test]$parted -l /dev/sda
Model: ATA WDC WD2500JD-19H (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End    Size    Type      File system    Flags
 1      32.3kB  50.0GB  50.0GB  primary  xfs            boot
 2      50.0GB  250GB  200GB  extended
 5      50.0GB  114GB  64.0GB  logical  xfs
 6      114GB  245GB  131GB  logical  xfs
 7      245GB  250GB  5049MB  logical  linux-swap(v1)

Error: /dev/md0: unrecognised disk label                                 
Warning: Error fsyncing/closing /dev/md0: Input/output error             

the listing for parted -l /dev/sda while booted to the gentoo install is identical except for the warning at the end.

Here is something interesting tho, while booted to vector:

[root@thor:m0rl0ck]$fdisk -l /dev/sda

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4b0c250a

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          63    97659134    48829536    7  HPFS/NTFS/exFAT
/dev/sda2        97659135  488392064  195366465    5  Extended
/dev/sda5        97662976  222586879    62461952  83  Linux
/dev/sda6      222588928  478527487  127969280  83  Linux
/dev/sda7      478529536  488390655    4930560  82  Linux swap

so fdisk is seeing it as a windows partition while parted and cfdisk are seeing it as xfs. It did originally have XP on it.

syg00 05-23-2012 12:13 AM

That'll do it to you.
The partition (type) id is rarely used (as you can see from parted), but it is sometimes. Linux won't install to NTFS - I think it will to VFAT, but why .... ???.
Change it to Linux - can be done on the fly without harm, but personally I'd do it from the liveCD (i.e.unmounted).

fogpipe 05-26-2012 02:49 AM

Heres the update. I called it quits on installing gentoo and took it back up again earlier tonight. I installed gentoo chrooted from vector linux instead of booted to the cd and im currently using firefox Xforwarded over ssh from my old celeron machine on the gentoo install while XDM and all its dependencies emerge. I emerged just enough to get fluxbox going with startX.

The drive appears to have settled down but my gentoo install stops during the boot and asks me to specify a root device, i think i can fix that but it may become another topic. thanks for the help :)

All times are GMT -5. The time now is 11:11 PM.