-   Gentoo (
-   -   Automatic wifi hotspot detect (

CollieJim 10-04-2012 02:27 PM

Automatic wifi hotspot detect
I have Linux Mint and Gentoo installed. Mint detects hotspots and allows easy connection.

My Gentoo system, as configured, needs detailed configuration in /etc/wpa_supplicant/wpa_supplicant.conf for each service or it is not seen.

What can I install to easily connect to a hotspot?


ShadowCat8 10-04-2012 06:24 PM


Well, I am not directly familiar with the program, but a quick 'emerge -s wifi' brought up the following on one of my servers:

*  net-wireless/wifi-radar
      Latest version available: 2.0.8
      Latest version installed: [ Not Installed ]
      Size of files: 61 kB
      Description:  WiFi Radar is a Python/PyGTK2 utility for managing WiFi profiles.
      License:      GPL-2


I took a look at the website and screenshots and I think it's what you might be looking for.

HTH. Let us know.

CollieJim 10-04-2012 09:52 PM

Thanks, but I think it might be Catch-22 *&^%$

Unfortunately the only Internet access is wireless...

I might be able to use wget under Mint to get the file, but dependencies might be a problem.

segmentation_fault 10-05-2012 09:10 AM

You can use wpa_gui for basic authentication set-up, and then dhcpcd to get the rest of the settings. That's to get your current gentoo system connected. Then look for a network manager. I have found wicd quite helpful.

CollieJim 10-05-2012 06:41 PM


wpa_gui gives me nothing for adaptor or network from which to choose. Scan finds nothing.

wifi-radar looks very promising, but it is asking for a wpa driver. I'm looking for that.

I briefly had access to a wired connection, but mostly I'm working through this by accessing the Internet with Mint, then rebooting gentoo to check out what I found. Tediuos.

i92guboj 10-08-2012 01:59 AM

I have no experience with Mint, but about any distro out there is using wpa_supplicant these days for this task.

So, what you want is a frontend to wpa_supplicant. That can be wicd, networkmanager or whatever you prefer. I don't use any so I can't really give you any hint about what's better.

If you want to get the list of files you will need to fetch to be able to emerge any package you just need to issue this command:


emerge -pf package_name > file_list.txt
Then use your favorite download manager in Mint, or wherever, to download the files. A simple "wget -i file_list.txt" will do.

ShadowCat8 10-08-2012 12:01 PM


I agree with i92guboj in that you should be able to point the driver for wifi-radar at wpa_supplicant.

If that doesn't work though, you can use 'lshw' to find out which driver the interface grabs and use that directly. At the very least, lshw will give you the chipset that the interface has so you can find the right driver for it.

HTH. Let us know.

CollieJim 10-24-2012 09:46 PM

Thanks for the help. I've finally had an opportunity to get things working.
wifi-radar wanted a WPA driver. I did not think to try wpa_supplicant. Is that what is wanted?

I did get wicd working. It has a curious problem: It works the first time, but reports that it cannot connect with dbus the next time. If I delete the logfile it works.

CollieJim 10-26-2012 07:02 PM

What am I doing wrong?
A few days ago I entered

emerge -pf wicd
and got a list of URLs for the files I needed to install wicd.

Today I entered

emerge -pf calibre
and got

[ebuild  N    ] dev-libs/chmlib-0.40-r1  USE="examples -static-libs"
[ebuild    U  ] dev-util/pkgconfig-0.27.1 [0.26] USE="-internal-glib%"
[ebuild  N    ] app-text/podofo-0.9.1  USE="boost -debug -test"
[ebuild  N    ] dev-python/six-1.1.0  USE="-doc"
[ebuild  N    ] dev-python/python-dateutil-2.1  USE="-examples"
[ebuild  N    ] media-libs/libwmf-  USE="X -debug -doc -expat -xml"
[ebuild  R    ] dev-lang/python-2.7.3-r2  USE="sqlite*"
[ebuild  N    ] dev-python/beautifulsoup-3.2.0
[ebuild  N    ] dev-python/mechanize-0.2.5
[ebuild  N    ] dev-python/cssutils-0.9.9  USE="-examples -test"
[ebuild  N    ] dev-python/imaging-1.1.7-r1  USE="X -doc -examples -lcms -scanner -tk"
[ebuild  N    ] dev-python/pycrypto-2.6  USE="gmp -doc"
[ebuild  N    ] dev-python/lxml-2.3.4  USE="threads -doc -examples"
[ebuild  N    ] dev-python/dnspython-1.9.4  USE="-examples"
[ebuild  N    ] app-text/calibre-0.8.62  USE="udisks"

How do I get the URLs again?


ShadowCat8 10-29-2012 02:36 PM


Well, one way is to make sure that you get the URLs you need is to check that you aren't connected on a network (which, iirc, is a given), and just run:

~ # emerge -f calibre >> ~/calibre-pkglist.txt
That file you create will be the output from the process of trying to grab the packages from all the different URLs it tried to download from, according to both the URLs within the ebuilds as well as the GENTOO_MIRRORS settings in /etc/make.conf.

Another way is to just go through the ebuild files for each listed version of each package there. A bit more time-consuming, but a bit less confusing for some.

Lastly, you *could* take the calibre-pkglist.txt file from above, and then run a 'grep | uniq' for the site closest to you to get a list of what you need to grab from one site.

I know that's a bit generic of an explanation, but if you have more questions, just let us know. :)

As a note, I tried it myself (e.g. running 'emerge -pf wicd' and then 'emerge -pf calibre') with portage- and portage- and got the list of URLs that you were seeing earlier for wicd but the packagelist for calibre... Not sure why the difference of behavior off-hand.
(P.S. Did you have any USE changes or package conflicts output from 'emerge -pf calibre'? That might be the difference. If so, it isn't ready to download them to begin with. I had a conflict with cairo vs. qt and 3 USE-flag changes from my list.)

HTH. Let us know.

CollieJim 10-29-2012 04:59 PM


If I had been thinking at the time, I would not have tried to get the URLs since I already had a connection thanks to the help with wicd.

I will pursue this for future reference.

All times are GMT -5. The time now is 11:47 PM.