-   General (
-   -   Wireless router trouble: successful connection but no internet access...DNS issue? (

R00ts 03-05-2010 01:34 PM

Wireless router trouble: successful connection but no internet access...DNS issue?
My router, a D-Link DI-634M, used to work just fine with our DSL internet when it was the only router in our house. Eventually my roommate had to replace it with his router because he couldn't get his VPN working with mine, so his router was connected to the DSL modem and my router was connected to his. My router still worked fine then.

Yesterday we got a cable modem and internet in addition to our DSL. I hooked my router up to it, but I was unable to access the internet. My roommates router is hooked up to it now and it works fine. So I tried connecting my router back to the DSL modem and I still can't access the internet with it. Its really frustrating because the device status (in the code box below) shows that everything is fine (I think). The router has an IP, a gateway, etc. and the log shows no errors, warnings or other problems. But no matter what I can't access the internet with it.

Here's what the router reports:

Device Information

Firmware Version :        2.01 ,    2006/01/10


MAC Address :        00:15:E9:5D:CD:30
IP Address :
Subnet Mask :
DHCP Server :        Enabled

Connection Type :        DHCP Client
Cable Status :        Connected
Network Status :        Established
Connection Up Time :        0 day(s), 0:07:55
MAC Address :        00:15:E9:5D:CD:31

Authentication & Security :        N/A
IP Address :
Subnet Mask :
Default Gateway :
Primary DNS Server :
Secondary DNS Server :

I never have a problem connecting to the router from any of my PCs. The only problem is that the router seems unable to deliver any internet traffic for me. Trying to visit a webpage with Firefox always returns "Server not found" after a few seconds of trying. Is this a DNS issue perhaps?

I've reset the router to the factory default settings and tried everything that I can think of. Any clues on what the problem may be and how I can fix it would be greatly appreciated. Thanks!

repo 03-05-2010 01:53 PM

Do you have an ip?

Can you ping the gateway (router)
Can you ping the outside?

Can you ping on name?

Dou you have the DNS configured?

cat /etc/resolv.conf

R00ts 03-05-2010 02:26 PM

Thanks for the quick reply. Unfortunately before I was able to do any of the tests you suggested I fixed it. I have no idea how/why it works now. I fiddled around with a few settings on the router:

- Enabled 802.11g Only Mode
- Set WPA Mode to WPA2 only
- Changed IP address of router

The IP address of the router was the same as that of the DSL modem, so maybe that was the issue. I'll test it with the cable modem later and see if that works as well. Anyway I'm just glad to learn that my router is not broken.

All times are GMT -5. The time now is 10:54 PM.