-   General (
-   -   Windows XP Installation Problem (

johnmtb 03-02-2013 09:49 AM

Windows XP Installation Problem
Dear All,

Although this question is not about Slackware Linux, maybe someone here can help me.

I recently built a new computer whose base is the ASUS P9X79 Deluxe Motherboard, and Intel Core i7-3820 Quad Core CPU. I have successfully installed Slackware Linux 14.0 on one of the 500 GB hard drives, and Windows 7, 64 bit on another.

However, I am completely unable to install Windows XP, Service Pack 3 on a third 500 GB hard drive; even with the other drives disconnected.

The problem is the SATA drivers.

I start up my computer with the Windows XP, Service Pack 3 DVD in the optical drive and a floppy disk with the SATA RAID Controllers in the floppy drive, pressing ‘f6', then ‘s’, when instructed.

I watched as iaStorA.sys was loaded from the floppy, but each time, after the Windows XP, Service Pack 3 DVD finished installing drivers, the Windows programme reported: ‘the file iaStorA.sys could not be found’. I don’t understand why it can’t be found, when I saw it loading!

I was able to install my Slackware Linux 14.0 without a murmur of complaint, so I need to know why I had no problem, and what SATA RAID Controllers Slackware Linux 14.0 has that enabled it to load so easily.

Please, I really need help to install Windows XP, Sevice Pack 3, on my new computer. If anyone can help me, it will be sincerely appreciated.



kfritz 03-02-2013 10:19 AM

This question is way off-topic for this list. I can't help you with your stated question -- you'll need to go to some Windows forum for that. I remember 10 or 11 years ago installing XP and having difficulties then.

But, let me challenge your need to install XP in the first place. Unless you're developing hardware drivers, you should seriously consider running XP virtualized. Virtualbox is a great way to start. It's even works on Slackware (if you're running 32-bit).

Habitual 03-02-2013 10:38 AM

How To howto Troubleshoot kbhowto site support microsoft com
686k 'How to' articles at microsoft.

natharran 03-02-2013 01:54 PM


Originally Posted by kfritz (Post 4903123)
...Virtualbox is a great way to start. It's even works on Slackware (if you're running 32-bit).

I agree that Virtualbox is a great way to start but you don't have to be running 32-bit. There's a 64-bit package available right from

Also, there are things that won't work in VM and you don't necessarily have to be developing hardware drivers. I was decrypting a DVD for backup purposes a few days ago and since I didn't find any reliable open source solution I had to do it in Win. And it only worked in Win installed on a physical hdd, in Virtualbox it crashed.


michaelk 03-02-2013 02:06 PM

Moved: This thread is more suitable in Non-*NIX Forums General and has been moved accordingly to help your thread/question get the exposure it deserves.

johnsfine 03-02-2013 02:45 PM

I have almost never used the method of getting a SATA driver from a floppy when installing XP.

Usually, the BIOS has some option to put the SATA ports into some kind of legacy IDE mode and/or turn off AHCI and/or other SATA features that XP doesn't understand (without a third party driver).

After disabling some SATA feature in the BIOS, install XP, then install the right SATA driver, then reenable the BIOS SATA feature that you needed to disable before installing XP.

All that worked on older hardware than you have. I haven't needed to try this in quite a while, so maybe it doesn't work on some hardware.

woodman 03-02-2013 07:30 PM

This might sound funny but unhook all HDD except the one that you want to put XP on. Now unplug the PC from the power source and push the power button and hold it for 60 seconds, then plug the PC back in and put the XP disc in and do a custom install some where it will ask you to format the drive choose yes and format to NTFS after you have installed the os with all the RAID drives reboot and see what happens. I have done this every now and then and it seems to work every time.

Good Luck!

lambo69 03-03-2013 01:18 AM

Try to build a new installation disc with the sata drivers, There's a tutorial.

m1bear 03-03-2013 10:00 PM

windows drivers
during the install it should let you inject sata/ide/raid drivers by I believe pressing F6 WinXP looks for these drivers on a floppy and the images come on your install CD for the ASUS MB. it should also have a program to write the floppy. I bet you don't have a floppy drive though so will do you no good. You are going to have to make a virtual floppy out of a USB pen-drive or simply try copying the drivers to a usb drive and find them when you press F6 I don's remember if it will let you do this. I have always had this same problem because I use RAID for windows.

well i hope this helps


johnsfine 03-04-2013 07:20 AM


Originally Posted by johnmtb (Post 4903107)
I start up my computer with the Windows XP, Service Pack 3 DVD in the optical drive and a floppy disk with the SATA RAID Controllers in the floppy drive, pressing ‘f6', then ‘s’, when instructed.


Originally Posted by m1bear (Post 4903995)
I bet you don't have a floppy drive though so will do you no good.

I don't know why the process you suggested, that johnmtb had already tried, didn't work. But I think johnmtb might have noticed if lack of a floppy drive was the reason it didn't work.

I don't see any suggestions in this thread for what might be wrong with that process or how to correct it. I don't have any such suggestions myself. I see three constructive suggestions (counting the one from me).

Install XP in a virtual machine (see posts #2, and #4)

Rebuild the install media adding the driver (see post #8)

Change BIOS settings while installing XP (see post #6)

m1bear 03-04-2013 03:48 PM

sry johnsfine you are right,

I guess I need to learn how to read again, sry was trying to help. but was kinda preoccupied with my own install problems with Slackware 14. Leave the floppy in until setup is done and look hard at BIOS setting I have a UEFI BIOS easy to move around with a mouse but I had a hard time setting it up, i am very used to updating setting. It looks like you might also have three different SATA controllers Marvell, Asmedia, and Intel X79 you could try plugging your HD into another controller.

( I have a Sabertooth 990fx R2.0 it came with a SATA notice telling me that 1-6 SATA ports where set to ahci I went into the bios and changed them to legacy/ide I still had to install a driver even to load my DVD Drive. The drivers on the install disk, for one of the controllers, did not work. I had to download a newer one from ASUS sight. Also, 11 Bios Updates might need to be updated.)

Habitual 03-04-2013 06:15 PM

Make a Vbox host, Add a FAT32 partition and format it.
Make it bootable (This part I am unclear about exactly HOW this is supposed to be done).

Copy cdrom\i386\* to the drive into an \i386 directory and cd \i386,
then run Winnt32.exe

You can even have answer files to automate the process.

johnmtb 03-05-2013 06:32 PM

Dear All,

thank you for your responses, unfortunately i have tried all the methods suggested, except the virtual machine, without success.

i know that it should install, but so far i have been unsuccessful, even reverting to IDE. my plan is to have Windows XP on one drive, Windows 7 on another; Slackware 14 is already installed on its own drive and is working properly.

but thank you all for your input.



All times are GMT -5. The time now is 12:15 PM.