-   General (
-   -   Unexpected Problem with XP (

Mandrake92 05-26-2004 08:01 PM

Unexpected Problem with XP
A couple of days ago i installed Mandrake 9.2 on a windows 98 se with a 4 gb hard drive with 3.5 gb free using the basic linux installer and partitioner and everything worked fine and it works great now...

now i tried to install mandrake 9.2 on a win XP home edition computer with a 30 gb hard drive with 16.5 gb free using the basic linux installer and partitioner..the installer was working fine but i have a problem with the doesnt recognize i have 16.5 gb free on the hard drive and says its 99% full which it only lets me resize the partition with win xp on it to 1mb smaller!!?

i went on microsoft website and read help files and tried to partition the drive manually through win xp and through dos but it doesnt work..

i dont know what to do :( and really need some help from someone who had experience with things like these..hope u can suggest something that will work

vdogvictor 05-26-2004 08:32 PM

Is you XP partition FAT or NTFS. I don't know if mandrake supports resizing NTFS. Anyways if the 16.5 GB free is part of a big XP partition then you need to disable virtual memory in XP, reboot, and defrag about 5 million times until all the data is at the begining of the drive

Mandrake92 05-26-2004 10:13 PM

yes my XP is in NTFS, and how do i disable virtual memory? and can anyone confirm if Mandrake 9.2 supports resizing NTFS partitions or not?? that really really sucks if it doesnt :(

vdogvictor 05-27-2004 12:03 PM

I know older versions don't support resizing NTFS for legal reasons...the only two ways to do it that I know of (w/out loosing data) are use a Knoppix cd and use qtparted or use SuSE rather than mandrake. to disable virtual memory right click my computer > advanced tab > performance settings button > advanced tab > change virtual memory to "no pagin file" then click set. I tried mandrake 8.1 or 9.1, I can't remember which because it didn't resize NTFS so I never used it.

Mandrake92 05-27-2004 02:20 PM

ok before the linux partitioner wouldnt let me resize my hd more than 1 mb, well i defraged 2 times not i can at least move the slider down to where i want it, allowing about 9 gb for linux but when i click partition it runs its thing then says partition failed cannot resize..if i get partition magic 8 will that work?? or can any1 suggest something cheaper that works good for resising NTFS on my WinXP

edit-- oh and when i defrag there is 1 big file that cant be defraged it says.
the file is /hiberfil.sys and its in 2 fragments totalling 512mb!
what is hiberfil.sys ??? and why is it so big!

vdogvictor 05-27-2004 04:37 PM

try turning off hibernation, suspension, and all the powersaving options then reboot again and defrag till it is all at the begining of the disk. As for cheap NTFS I said use Knoppix or SuSE or yes partition magic works...i'm not sure what version though. if 8 is the newest one then yes.

Berhanie 05-28-2004 01:43 AM

here's an easy way to resize your ntfs partition:

1. download SystemRescue-CD (105 MB) and burn onto CD-ROM.
2. boot from CD.
3. at root prompt, type "run_qtparted".
4. resize your partition (qtparted is a gui, so it's "intuitive": click on partition to be resized, choose to resize, enter new size. when done, click on the disk icon and the resizing will take place).
5. when windows boots the next time, it'll perform an integrity check on its partition, so don't be alarmed by that.

Mandrake92 05-28-2004 09:39 AM

i have a computer that has a cd/rw drive but the laptop im trying to install it on cant read the cd/rw nor can it burn anything. is there any other way to run SymantecRescue other than having to boot from the cd which my laptop cant read?

XavierP 05-28-2004 09:48 AM

As this is more Windows related than Linux, this thread has been moved to General

Berhanie 05-28-2004 10:52 AM

this lists some cd- and floppy- based distributions that support ntrsresize.

All times are GMT -5. The time now is 06:13 PM.