-   General (
-   -   trying to install the software Rosetta Stone through wine (

gerlinux 03-22-2014 07:51 AM

trying to install the software Rosetta Stone through wine

I am trying to install the software Rosetta Stone in my computer.

For doing that, i have installed wine version 1.4.1, I have the rosetta software in 5 iso files, tried to open the first iso file with wine and got this error message from wine: There is no Window program configured to open this type of file.

Does someone knows what can i do to install the software that i want to install? I would like to install it to learn French.. :)

thanks in advanced.


business_kid 03-22-2014 08:39 AM

It's important to feed the errors back to the thread. I would update wine if you could. I have a fairly recent git and that's version 1.7.13-stuff. Also get the winetricks script as it installs a whole lot of stuff you will be stuck for otherwise.

The basic process to mount an iso (Not on cd) is
modprobe loop
mount -t iso9660 -o loop /path/to/your.iso /somewhere where somewhere is a directory. use /mnt or a subdirectory of it - don't bang it on a full dir.

then wine /path/to/setup.exe

Feed back the errors.

gerlinux 03-22-2014 09:34 AM


i am afraid i forgot to say that i am a newbie, i am using debian since a few months ago..and don't know lot of things..

i have download a package with wine-1.7.13 and tried to follow the instructions which are in the readme document.. but i haven't been able to install it.. the package has the .tar.bz2 extension.. do u know an easy way to install wine- 1.7.13 software in debian? the only thing i have done is to reinstall the old version of wine i had..


i would appreciate if someone could give me a hand..


snowpine 03-22-2014 09:41 AM

A must-read site for Wine users is the Wine HQ App Database where you can read if a particular app is well-supported by Wine.

When I go on the page for Rosetta Stone I see that different versions get different ratings, from "platinum" (well-supported) to "garbage" (completely unsupported and you are wasting your time).

So the question is, which versin of Rosetta Stone are you trying to install, and what is its rating in the AppDB? :)

gerlinux 03-22-2014 09:48 AM

I am trying to install rosetta v3 and the rating in not to bad :)

thanks for replying.


snowpine 03-22-2014 09:53 AM

Did you see there are 19 test reports and 1 comment in the App DB for Rosetta Stone v3? Did you find them at all useful/helpful? Were any of them applicable to the version of Debian you are using, or are they all old/outdated? Do you still think upgrading to Wine 1.7.13 is the necessary solution? Are you using official purchased Rosetta Stone v3, or a sketchy torrent? (The reason I ask is, not to accuse you of anything, but because when I web-search for "Rosetta Stone v3" the 4th most popular link is a TPB site that says "Doesn't work. After installing the program and crack the program, upon launch, prompts to add a language, deactivate a language, or quit rosetta stone with no other options.")

Do you have access to a Windows computer, which should presumably run the legitimate commercial version of this software flawlessly? :)

gerlinux 03-22-2014 09:59 AM

i saw the comments and the only one which is from a debian user it says that is couldn't even install rosetta stone software...

i only have the computer i am using now.. with debian on it.. :S

there must be a solution to this problem, inn't? but how knows wich one.. :P


thanks again.

snowpine 03-22-2014 10:02 AM


Originally Posted by gerlinux (Post 5139274)
there must be a solution to this problem

Do you know anyone who speaks French? ;)

gerlinux 03-22-2014 10:03 AM

haha..not in my hometown..

people barely speaks spanish here! :P

business_kid 03-22-2014 02:39 PM

tar -jxvf /path/to/your.tat.bz2

That will give you a directory full of stuff, which probably needs compiling. Read the README and INSTALL files and don't bother with wine64 bit unless Rosetta stone is 64 bit.

If you're a newbie, try for a package. Debian (or Ubuntu, which also uses the debian package manager) is bound to have later than 1.4.2 - They have some stuff in their 'bleeding edge' archives.

gerlinux 03-22-2014 03:08 PM

I typed tar -jxvf /path/to/your.tat.bz2 in the terminal and this is the message i got it:
tar (child): /path/to/your.tat.bz2: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

thanks for your replying anyway :)

sgosnell 03-22-2014 04:20 PM

You replace /path/to/your/tat.bz2 with the actual path. No one knows the actual path on your machine, so it's a standard shorthand to use this.

gerlinux 03-22-2014 06:07 PM

I'm terrible and ignorant about linux..

I am less than a complete beginner..

don't know how to replace the path.. or even what is a path..

shall i quite trying to install the rosetta stone.

sorry about my negative attitude but I am trying to install it for hours and not noticing any progress.

thanks to all

sgosnell 03-22-2014 08:54 PM

The concept of path is the same in Windows, Linux, or OSX. It's a pointer to a location. Thus if you saved the file in /home/gerlinux/Downloads, that's the path you need. On Windows, it might be C:\Users\My Documents\Downloads, or whatever. You have to tell tar where the file is, it can't know on its own. Same for Winzip on Windows. This is basic computer literacy. Whether you quit trying to install Rosetta Stone is up to you. It is always easier to run a program on the same OS it was compiled for, and Rosetta Stone only targets Windows users, because they're willing to spend their money on software. Almost all Linux software is free.

business_kid 03-23-2014 04:43 AM

to sort out path in linux is easy enough. I remember doing it myself all those years ago.

Dos/Windows \ is linux /, so 'cd /' takes you back to the root of the directory tree
cd ~/ takes you to your home directory.
Try this in a terminal


cd ~/
find -name '*.iso'

with any luck you will see those iso files in the list, in the form

for example.
You can put all of that after tar -jxvf

All times are GMT -5. The time now is 02:37 PM.