-   General (
-   -   Samba network and windows8...anyone? (

ahzthecat 12-03-2012 06:56 AM

Samba network and windows8...anyone?
Off topic or even out of bounds, but I have to ask. Has anyone else had trouble getting windows 8 to connect to existing samba networks?

I have a server running slackware 13.37 using samba to manage my home network. It has been great...solid stable and smooth. I picked up a cheap netbook this summer and when W8 dropped I took advantage of the discount upgrade option. Now I have an Acer Aspire running w8 that refuses to even see my home network. It's not a hardware or samba issue because the acer saw the network just fine under w7.

I've googled and googled and haven't found any answers and it's making me crazy. I'm a linux guy who just wanted to tinker with w8, but it's really a nightmare to work on. Slackware? Easy. W8, fscked.

I know this is LinuxQuestions, but I live here and the folks at LQ are the best, most informed IT gurus I know. Any help would be AWESOME. Commiseration is also welcome.

set up a vm inside w8 with ubuntu, and guess what? It sees the domain and server just fine! W8==JUNK!

jschiwal 12-03-2012 10:29 AM

Which version of Windows did you use before. At work, a windows 2008 server couldn't see the shares of my Widows 7 decoder. It turned out that I needed to change the number of bits used for encryption in Windows 7.

Check the firewalls on both machines. Is samba browsing allowed.

Check if winbind is used. Is the IP address for the wins server correct. This might be configured by dhcp.

If Win 8 uses home groups, you might need to use a work group instead.

ahzthecat 12-03-2012 06:40 PM

Upgraded from w7 to w8, everything was connecting properly in w7. I've turned off the firewall for private networks in w8, still no luck. At this point I'm just throwing any fix I can find at.
This homegroups and workgroups thing has got me mixed up as well. In w7 all I had to do was rename the workgroup on the pc to the workgroup of my server and network and things just worked. I've renamed the workgroup in w8, but that hasn't helped either.

Encryption is off, credentials have been cleared and reset... what a mess.

Being up to your elbows in a linux system is fun, you feel like you're fixing something. Up to your elbows in w8 just feels...dirty.

All times are GMT -5. The time now is 03:59 PM.