-   General (
-   -   Network completely stops working in windows XP (

Baldho 06-14-2004 02:15 PM

Network completely stops working in windows XP
Hi! I know this is a linux forum, but i've read someone else's post about a WinXP related problem and i saw he got great help here.

The problem is quite simple... At any time, the little network dialog says that no packet have been recieved, and no packet have been sent. My network has a DHCP server, and WinXP can't get its IP (sent and recieved packets stay to 0)

I have two other Windows computer on my network (and one Debian) and they both work perfectly on the LAN.

I tried another NIC with no success.

I Also tried SFC and a WinsockFIX that used to work very well in those situations (it resets the TCP/IP protocole).

Also, when i run a network game of Diablo 2 with a fixed IP and netmask, here is what i get:

Location: D2Net\SRC\Client.cpp, line #108
Expression: Socket

And when i try to host a game at Half-Life (or a mod like counter-strike):

Couldn't allocate multicast IP port

As for Age of Empires 2, the TCP/IP protocol isn't even listed in the connection types.

Thanks in advance.

Baldho 06-16-2004 01:29 AM

I also tried the sfc tool without success...

bobemitc 06-16-2004 04:23 AM

Try using static IP addresses for all boxes - i.e.
The internet-connected box (gateway) should be

I've had trouble before and this seemed to solve it.

However, your game errors make me wonder if it's not software. Do you have a spare hard disk, upon which you can do a clean windows install? If so, remove the computer's main disk, and put in the spare. Install Losedows and your games (DO NOT ACTIVATE windows, doing so too many times will disable your license key...!) and try again.

The NIC - same model, same brand, or completely different? Also try to get updated drivers, and try both the built-in windows drivers and the packaged drivers for the card.

Lleb_KCir 06-16-2004 09:42 PM

sounds like one of a few things.

first update the drivers for your NIC from the manufacture.
second try a complete rebuild of the TCP/IP stack on your NIC.

if neither of those work, then swap the cable to a known good port on your hub/switch.

if that fixes it, then you know what the problem is, if still same issue, swap the cable with a known good cable and keep it pluged into a known good port on the hub/switch.

one of those steps should fix the problem.

Baldho 06-22-2004 03:10 AM

i had a Ghost image of my winxp installation. I got it back on my HD and everything went back ok.

Before doing that, i got sure the problem wasn't on the LAN itself since other computers could use my cable and access the network. I also changed the NIC drivers.

The other NIC card was the same brand i think, i tried that just to know if the NIC was dead. So the problem was either my root hardware or my winXP.

So now i know it was winXP. I miss win9X for one thing: we could uninstall and install back the tcp-ip protocol...

Oh and i also tried to re-install the WinXP SP1.

All times are GMT -5. The time now is 01:29 PM.