LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   General (https://www.linuxquestions.org/questions/general-10/)
-   -   how to mount sharepoint onto linux local? (https://www.linuxquestions.org/questions/general-10/how-to-mount-sharepoint-onto-linux-local-712435/)

suresh.bonda 03-18-2009 04:31 AM

how to mount sharepoint onto linux local?
 
Hi,

I was trying to mount a sharepoint directory onto my linux box.
I already had gone through most of the posts on various sites and nothing
worked. If anyone had really succeeded in mounting sharepoint on linux
as local directory? If so, could you please help me in doing so.

---------------------------------------------------------------------
Few Details:
sharepoint can be mapped onto my local windows using my Windows NT
authentication
NT username (DOMAIN\username)
NT password

username on linux is not the same as NT username.
---------------------------------------------------------------------

I tried mounting using davfs (for that I download davfs and neon).

when I tried the mount command its asked for username and password for
proxy server first and then the site. somehow I managed to get rid
of the proxy authentication. But when I now try to mount by giving
my DOMAIN\username and password. I get "/sbin/mount.davfs: Mouting failed
401 Access Denied".

somewhere I found nautilus by default can use davfs type filesystem
to display as file folder. Even that says "Access denied" when I try
the sharepoint URL.

I can logon to the site using my class B digital certificate, so I
tried the find in the configuration if I can give my digital certificate
path to get rid of entering username and password for authentication.
I was unable to find.

Few confusions were i have a create a user davfs2 and group davfs2 to
run the mount command, why this davf2 user and group are needed?

I tried other things such cadaver, webdav, fusedav. Now I feel like
I am totally lost... I am trying to do this for the past several days.

I am expecting help from people who have succeeded in mounting
sharepoint to linux.

Thank You,
Suresh Bonda

suresh.bonda 03-18-2009 06:28 AM

self replying trying to keep my thread among top so that it doesnt get lost in so many posts... ;)


All times are GMT -5. The time now is 01:49 PM.