-   General (
-   -   freedos (

synoptyck 03-15-2013 05:06 AM

I have some trouble with freedos...
I create it with...

./ -lba --disk=freedos.img
DOS boot sector for freedos.img will be created by:
  nasm -o /dev/stdout  /usr/src/bootsecs/boot32lb.asm
Using FAT32 LBA. Partn offset 0, CHS *x64x32  Drive 0, (0x0, 0x29),
SerNo E8A4-6661, Strings '          ',  'FAT32  '.
Boot sector successfully updated.

But it not use this command...

here my image for 64mb.

mjolnir 03-15-2013 10:01 AM

I don't have a clue about what's wrong but if no one comes along who has an answer you might find a lot of help here:

I recently installed FreeDos 1.1 from a cd and have had some fun fooling around with it on a very old laptop.

synoptyck 03-15-2013 06:44 PM


I recently installed FreeDos 1.1 from a cd and have had some fun fooling around with it on a very old laptop.
Could you mount this image in linux wich you made from livecd of freedos?

mjolnir 03-15-2013 07:27 PM


Originally Posted by synoptyck (Post 4912580)
Could you mount this image in linux wich you made from livecd of freedos?

I'm reasonably sure one could with something like:


mkdir freedos
mount -o loop freedos.img freedos/

I d/l the iso to the windows side of my laptop and burnt it to cd from there. Then did the install. What exactly are you trying to do? Install Freedos or something else?

synoptyck 03-16-2013 04:57 AM

I want make an image with free dos.
If you have installed freedos, could you make an image with that?

because I've tryed install from livecd, but anyway I can't mount freedos derived from livecd install. But mount will work fine if I makeing it from linux script.

But end of my trouble in loading freedos from my image, as you can see on this image on the first message. Kernel is loaded fine, but not sencible.

no, I've made image from fdbasecd.iso, I can mount fs in both win\nix sytems, but loading stopped on
Loading FreeDOS
i.e. it is not touching the kernel.
What iso image you use for freedos instalation?

mjolnir 03-16-2013 08:53 AM

I used fd11src.iso from here:

Benny7440 05-10-2013 11:15 AM

Have been using an old hdd-less hp laptop with DSL in an old 64MB MP3 player &, since that laptop has a 3.5" FD I've been trying to install freedos in one such diskettes from there but the process has failed me.

There's a diskette .img file to d/l for such purposes & I've put it in the diskette but it fails to boot. Recently, I've read somewhere that I should use the dd command to make the image on the diskette "without" mounting the device first. I remember that I mounted the diskette first & then put the image there from DSL file manager: did I made a mistake there? What's the difference between mounting first or not?

Thanks for reading this & especially for any replies!

mjolnir 05-13-2013 09:02 AM

This site has links to what are supposed to be live floppy and cd images. Try at own risk.

"Balder requires NO hard disk install, therefore requires no hard disk partition or other dangerous activity. Everything is on the floppy you boot from.

Freedos is also available as an iso for CD in a 39MB installable version - no live version just now. Note- now version 1.1. Note that installing Freedos may overwrite other operating systems or data on your computer. A live CD iso of version 1.0 is available at Freedos 1.0 live CD- download the 153MB iso.

The img file for Balder you have downloaded from the link above needs to be placed onto a real (formatted) floppy as a bootable image-
in Linux the command is:
dd if=/fullpathto/wheretheimagefileis/odin1440.img of=/dev/fd0

where fd0 is the device name in my system for my floppy drive, which for the purpose of this command should be unmounted (a Linux thing). It will be fd0 for the first floppy drive in almost all Linux systems."

I haven't tried them so good luck.

Benny7440 05-13-2013 05:27 PM

Thanks, mjoinir, for replying!

Followed your instructions well but nothing happened. Downloaded Balder (2007) & used the dd command with fd0 unmounted. First it refused because there was already an image of frreedos in there. I reformatted the disk as 1440KB & tried it again. It took a really long time but finished without any errors.

There's something curious though, I d/l the image file from the ibiblio repository & when I checked for the file its name was changed to "z5f820we,exe" from "odin1440.img". I then renamed it back to its original name & extension. Now, I'm wondering what might happen if I rename it as an .exe file? Any ideas?

mjolnir 05-14-2013 04:19 PM

Yesterday when I posted I d/l both supposedly "live" .img from the site. My floppy image is named "balder10.img" and the iso is "fdfullcd". I haven't had time to try them though.

The floppy image came from here:

I just noticed that his dd command has "odin1440.img", that would have to be changed to the appropriate name.

Habitual 05-14-2013 06:08 PM

I still have Win 3.1 Disk Images here abouts...

All times are GMT -5. The time now is 07:33 PM.