LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   General (https://www.linuxquestions.org/questions/general-10/)
-   -   Chkdsk command for a USB storage disk (https://www.linuxquestions.org/questions/general-10/chkdsk-command-for-a-usb-storage-disk-4175690019/)

linuxlivecd 02-06-2021 02:57 PM

Chkdsk command for a USB storage disk
 
1 Attachment(s)
Hey there,

Well I'm trying to get this Command to work for a USB drive, it gave this. Nothing.

https://wintechlab.com/disk-structur...iles%20in%20it.

Quote:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Handygeek>chkdsk G:
The type of the file system is NTFS.
Volume label is USB.

C:\Users\Handygeek>chkdsk G:/r
The type of the file system is NTFS.
Volume label is USB.
Corrupt master file table. Windows will attempt to recover
master file table from disk.
Windows cannot recover master file table. CHKDSK aborted.

C:\Users\Handygeek>

linuxlivecd 02-06-2021 04:30 PM

could it be that, there isn't a way to keep the disk functioning as is? It had duplicate backups. I recently just loaded a publisher file on it, beginning of the month. So I don't know what caused this error. It hasn't ever happened before. I have used this since November 2005.

enorbet 02-06-2021 04:54 PM

I'd backup the files to hdd and try GParted from Linux. Just rt-clk on it, unmount it if it says it's mounted, and select "Check" and apply. Just FTR my brother sent me a hard drive from his Win 10 machine that had trouble booting for some time and finally would do nothing on his box. I tried fixing it in Windows and not only did it fail it was a PITA. Linux tools fixed it enough so that Windows tools COULD finalize it.

linuxlivecd 02-07-2021 10:37 AM

1 Attachment(s)
I don't have a copy of linux installed on here.

I decided just to do a format, NTFS. I had used it briefly was the PS2 project I tried late last year, FAT32, a system before my time. From twenty five years back, no doubt.

So I did a format as NTFS, and transferred duplicates from another storage USB I have, I have lost a few files, not to many that are important. GTA vice city, some Zanoza Modeler old files, but they were mainly, backed up on the other one. Blender files. A few publisher files. Those actually only on here, at the moment.

Here is the screen of the result of doing a format.

I load a 45mb file onto it, then removed it, but the disk doesn't seem to adjust the amount used. When I inserted the disk again, the removed file was still on there.

teckk 02-07-2021 02:30 PM

I don't have any idea what you are doing. That pic says that you have a 62.2MB external disk, and 11.7MB is used, no doubt for the file system.
What size is that external USB drive suppose to be? Does that drive have a partition on it? Need more info.

What is the output of
Code:

lsusb

fdisk -l


linuxlivecd 02-07-2021 03:53 PM

2 Attachment(s)
It is a USB storage drive, not a hard drive. 64MB. I stored two files on it so far.

So why is 8mb in use, if there is only these small files? I noticed a Floppy disk I have, had some files, duplicates of pocket pc programs I crappy made more than seven years ago in Visual studio 2003, no good at programming, with what little there was I put something small game together, shooting asteroids. It then had a message load, need to format, so I did, and used it again for a small modded game file, I backed it up on several floppy disks.

So it reminded me of what happened with the USB storage.

Not sure what the code would be more, I can't use that in cmd for windows, bare in my mind. I haven't had a linux install easy access for some years. On another drive I have linux distribution with windows. But that isn't for use with the primary other system I have for windows 7 which has its own drive. On here, the drive keeps opening up, showing my publisher files.

May be it is knackered, don't these USB's eventually pack up?

linuxlivecd 02-08-2021 12:38 PM

1 Attachment(s)
I tried the disk again, just now.

So the same two publisher files on there, and this is what the usage displays.

enorbet 02-09-2021 03:20 AM

Just FTR, even if you don't currently have Linux installed that's not a problem at all. LiveSlak is a full operating system (not skeleton glitz for a UI installer) runs on optical, or better, USB (which has persistence) and has a c complete set of tools inluding gdisk and GParted by default. If what it has default isn't enough for you, you can easily install just about anything else either from source or packages (that are auto-built from source on your machine). It will be important to do some reading as Slackware is designed for power and customization not convenience. You would need to be or become an Admin.

linuxlivecd 02-12-2021 11:39 AM

So I can burn this to a DVD r to run this slack ware os?

enorbet 02-13-2021 12:10 AM

Quote:

Originally Posted by kalilinuxlivecd (Post 6219525)
So I can burn this to a DVD r to run this slack ware os?

Yes. There are built-in scripts to setup either Optical or USB and even to HDD. Recently I began switching all my installs, Windows and several distros, to UEFI boot from Legacy MBR and LiveSlak was invaluable to me. For example with Persistence enabled it was easy to mount partitions, use GParted or gdisk to setup ESP, and chroot in to run efibootmgr, eliloconfig, or install rEFInd. The completeness including development tools is excellent! Kernels are always very new. Even my new Z490 system with the Intel WiFi 6 AX201 @160MHz just worked "out of the box". There are several versions to choose from like with your choice between Plasma5, Xfce, Mate, Cinnamon, and even a working complete DAW.

You can find some here https://repo.ukdw.ac.id/slackware-live/latest/ but I recommend the 4.1GB Current. All the rest can be installed later if you want, just like a regular release install. Incidentally you will see the oldest image there is 12/28/2020 and newest as of today, is 1/18/2021.

linuxlivecd 02-13-2021 02:54 PM

3.3 Slackware 14.2

This I should send this using imgburn to a dvd, from last year that version. So once it is on there, I just simply select the drive to fire up the disc, and from there it will go into this slackware os, and what is next?

linuxlivecd 02-14-2021 10:45 AM

I am writing a copy to a DVD, so 3.3GB will fit fine on the DVD, write at 8x speed.

I am going to need a few pointers here, on what do I do, I select the disc drive from startup to load into this slackware, and do what from there to select the USB drive and repair the structure.

Emerson 02-14-2021 10:52 AM

Quote:

Originally Posted by kalilinuxlivecd (Post 6217138)
It hasn't ever happened before. I have used this since November 2005.

Lasted pretty long, RIP now, I guess.

linuxlivecd 02-14-2021 11:04 AM

2 Attachment(s)
What do you mean? I am wasting my time with the slackware os try? I have got it on disc. So what is next?

I tried to just copy 12mb of FCMB, so mcfreeboot for the PS2, just some old files from the Linux for PS2 files I still happen to have.

I removed the video file, and then tried to copy the FCMB folder. I had to skip them all, only a folder there now.

ondoho 02-14-2021 11:08 AM

Quote:

Originally Posted by kalilinuxlivecd (Post 6220206)
What do you mean?

They meant that if a hard drive has been in use since 2005, it's probably time to say goodbye to it anyhow.


All times are GMT -5. The time now is 12:21 PM.