-   General (
-   -   [SOLVED] whassup w/ this package...? (

Alexvader 09-16-2010 03:38 PM

[SOLVED] whassup w/ this package...?
Hi Forum

There is an open ASCII format for 3d/2d drawings, it is called dxf, it was created by Autocad, but its specifications are open, ( unlike the DWG format ), Open Design Alliance has created some utility programs to convert between the binary format dwg to dxf... but this only runs in winblows ( wine ).

I get some files which contain sections of objects I have to work with, in pdf. And I have found this package, pdf2dxf, which is supposed to convert an image in the pdf file to a set of points, straight lines and splines in a dxf,, but when I try to download the source, the link seems dead or it points to no tar package...

Does anyone know if the source of this exists... ?

Sourceforge reports nothing ...




Nevermind... :D Solved this already
This is just a little bash script that uses Qcad, which I do not have... I am running Slackware 13, and there is no Slackbuild for it... and it is not an "easy" package to build...

Solved... :)

b0uncer 09-23-2010 04:26 AM

The (tar) archive you pointed, pdf2dxf, is downloadable--at least it worked fine for me. However the tar package consists of one simple file: a desktop launcher. Therefore you don't actually need that; what you'd want from it is the actual command that it runs, which I quote below (contents of the pdf2xdf.desktop file). In order to use it you must have the program it runs, pstoedit, so you'll need to locate that first.


Originally Posted by pdf2dxf.desktop
# Author: Claus Mueller ( claus at open-craft dot org)
# Licence: GPL
# version: 0.1
# see for more details on howto create kde service menu and for howto use kdialog

[Desktop Entry]
X-KDE-Submenu[de]=PDF in DXF konvertieren
X-KDE-Submenu=convert PDF to DXF

[Desktop Action pdf2dxf]
Name=pdf2dxf (default)
Name[de]=pdf2dxf (Standard)
Exec= pstoedit -f dxf "%u" "`echo "%u" | sed -e 's/.pdf/.dxf/g'`"

Note the bold text--that's what this is all about.

Edit: apparently there's a Slackware package of pstoedit available (at least has one, or you can build one yourself), so that should solve it. Also, when you solve your question, please edit the title to say [SOLVED].

All times are GMT -5. The time now is 08:36 PM.