-   Fedora - Installation (
-   -   Will laptop Fn keys work in F18 actual if not working on 'Live USB'? (

memilanuk 06-24-2013 07:42 PM

Will laptop Fn keys work in F18 actual if not working on 'Live USB'?
I've been bouncing around distros a bit lately on my Lenovo ThinkPad T530, dual-boot with Win7. Almost all the Fn keys (such as Fn+F3 for 'lock screen', Fn+F4 for 'sleep', Fn+F5 to disable wireless radios, Fn+F6 to activate the webcam, Fn+F8/F9 for screen brightness) work as is, 'straight out of the box' with no fiddling in Ubuntu 13.04 - though oddly not in Xubuntu 13.04? Most of them work in openSUSE 12.3; less than half work in Mint 15, and so on. I recently booted a live USB of Fedora 18, and basically *none* of these Fn+Fx key combinations worked... which has me seriously questioning whether its worth the effort to even bother try installing on this particular hardware platform... is the 'Live DVD' (or USB) generally a good indicator of whether a particular function or hardware item will work with the distro in question?

Virneto 06-25-2013 04:04 AM

In my Fedora 18 installation they're not working. I donít remember if they were working on live CD and I'm not even missing them at this point. But of course that depends on my needs.
Also note that since Iím not missing it I haven't even tried to make them work, wish Iím sure its possible.

memilanuk 06-25-2013 04:17 PM

Most of them I'd probably be able to 'live without'... but not having functioning brightness controls (at all) on a laptop is pretty much a no-go for me. I'd imagine it's probably kernel-related, as Mint15 had everything working except brightness (nothing at all changed it, Fn+Fx keys or anything) until a recent kernel update to and now they work as advertised. I suppose since the Fedora 18 install image is a bit older may be why the Fn keys don't work from the Live instance? Eh. Mint 15 is working pretty much all the way around for now; think I'll hang out there for a bit as I'm getting tired of re-installing stuff.

911InsideJob 07-27-2013 06:36 AM

All the function keys on my $300 Gateway laptop are working with Fedora 19. It's a bit of a pain actually, as Gateway does it back-ass-wards: you have to press shift for regualr functions... so when I want to press F3 (voting in Red Shift game) and forget that peculiarity I accidentally shut off WiFi. :doh:

I think it's more a function of your desktop environment that distro actually. Works with Gnome3 on all distros I've tried... don't know about KDE or lightweight DE/WMs.

Virneto 07-27-2013 09:52 AM


Originally Posted by memilanuk (Post 4978574)
.. but not having functioning brightness controls (at all)(...)

System Settings >> Power Management >> Energy Saving >> Display Brightness

memilanuk 07-28-2013 09:53 AM


Originally Posted by Virneto (Post 4997867)
System Settings >> Power Management >> Energy Saving >> Display Brightness

Yeah... when I said not having any brightness control at all... I meant *AT ALL*, including that.

All times are GMT -5. The time now is 01:28 PM.