-   Fedora - Installation (
-   -   Unichrome Pro Integrated Video Help (

jmikeneedham 04-27-2007 07:57 AM

Unichrome Pro Integrated Video Help

I have a new Abit IP-95 mainboard that I just bought and installed Fedora Core 6 on. The on-board video chipset is the VIA Unichrome Pro P4M890.

I just bought a TV card (Hauppage WinTV Go Plus (Model #1033) and downloaded TVTIME through yum.

Currently my X-server is setup using the standard VESA driver and I need to get the actual drivers for the video card, I have some that I downloaded from that were marked as for the P4M800 series (DRI drivers), but I can not seem to get them installed on my system.

The Error I get when running minstall is:


[root@localhost DRI]# ./minstall
 -------- minstall start --------
cp: cannot create regular file `/usr/X11R6/lib/': Is a directory
ln: creating symbolic link `/usr/X11R6/lib/' to `/usr/X11R6/lib/': No such file or directory
ln: creating symbolic link `/usr/X11R6/lib/' to `/usr/X11R6/lib/': No such file or directory
cp: cannot create regular file `/usr/X11R6/lib/modules/extensions': No such file or directory
 -------- minstall end --------

I assume I need these drivers for my overlay on the TV card to work.

The TVTIME error is:


[jmneedham@localhost ~]$ tvtime
Running tvtime 1.0.1.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/jmneedham/.tvtime/tvtime.xml
xvoutput: No XVIDEO port found which supports YUY2 images.

*** tvtime requires hardware YUY2 overlay support from your video card
*** driver.  If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers:
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.

Help getting these things working is GREATLY appreciated!

hollywoodb 04-28-2007 11:45 AM

use Yum to search for a unichrome-type package:

yum list \*unichrome\*
If you can't find anything, or can't find any packages anywhere, the following website is probably a better source than Via itself:

deepclutch 04-29-2007 04:03 AM

Opencrome drivers are the solution
for via unichrome pro cards to work in Linux(Debian user) u need to install drivers.the method to install these drivers and editing ur /etc/X11/xorg.conf is listed below posted by me in other forum:
I also have via unichrome is not supported very well in GNU/Linux.solution is to get open chrome rpms installed.I'll show u the link.
for this u first need to be root(administrator user) user.
so in the B/W screen with "$" prompt type:

~$ su -

press enter and give the root's password.
u'll get a "#" prompt
before that u need to edit ur /etc/X11/xorg.conf using nano editor like

~#nano -w /etc/X11/xorg.conf

note the space between!
now search and find the section with Section "Device"
and edit the section to fit the driver to vesa.

Section "Device" Identifier "Generic Video Card" Driver "vesa" EndSection

save the file by pressing CTRL+O ,CTRL+X save when prompted.
reboot for gnome gui.
afterwards u can download the rpms for via unichrome pro igp from:
download only these rpms:

install these rpms like:
As root user "#" prompt:

~#rpm -Uvh foobar.rpm

or by double clicking on the rpm file in Fedora.
Now again edit ur /etc/X11/xorg.conf and change the Section "Device" as follows using nano editor as earlier:

Section "Device" Identifier "Generic Video Card" Driver "via" Option "EnableAGPDMA" "On" BusID "PCI:1:0:0" EndSection

save and exit.reboot or restart X server for GUI working.

jmikeneedham 04-29-2007 10:27 AM


Thanks for the help so far, I am thankful to you all for the help this far.


I downloaded the RPMs you suggested and I get the following Dependency errors when trying to install the packages:


Missing Dependency: mesa-libGLU = 6.5.1-9.fc6 is needed by package mesa-libGLU-devel

Missing Dependency: mesa-libGL = 6.5.1-9.fc6 is needed by package mesa-libGL-devel
These are in a dialog for "Unable to resolve Dependencies" in the Software Installer App.

Also, just wondering as I read your post, is the fact that my motherboard is PCIe going to make a difference when I go to configure the X-server? I noticed you said to set the option "EnableAGPDMA"....

Anyhow, not sure, but unable to get the Mesa drivers you specified installed.

deepclutch 04-29-2007 12:50 PM

those mesa drivers are in the repository.i posted download and install.
just download and install these rpms.

jmikeneedham 04-29-2007 02:26 PM


Yes, I downloaded the RPMs and tried to install them and I get those dependency problems when trying to install the RPMs you posted.

Here is the command line output for when I tried to install the RPMs from the repo you suggested.


[root@localhost OpenUnichrome]# rpm -Uvh mesa*
error: Failed dependencies:
        mesa-libGL = 6.5.1-9.fc6 is needed by (installed) mesa-libGL-devel-6.5.1-9.fc6.i386
        mesa-libGLU = 6.5.1-9.fc6 is needed by (installed) mesa-libGLU-devel-6.5.1-9.fc6.i386

Just thought that would help :-)

deepclutch 05-01-2007 09:58 AM

^ what u faced is called dependency hell.Ofcourse U can install those rpms from the link i gave using rpm -Uvh --force xxxx.rpm
smart package management is there.Now I must say U should try Yum:
How to:
open a terminal as root

~$su -
^^ give root's passwd

~#gedit  /etc/yum.repos.d/epia.repo
IN the editor add these lines as it is:

name=RPMs for Via Epia motherboards - Fedora Core $releasever - $basearch

Now save the editor and exit
then install using from a terminal as root:

:~#yum  -y mesa-libGL  mesa-libGLU
There is a gui tool called pirut in Fedora afaik.
that will solve ur problem.also check ur /etc/X11/xorg.conf for lines:

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "dri"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "vbe"

and Section "Device" should be edited to look like:

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "via"
        BusID          "PCI:1:0:0"
        Option  "EnableAGPDMA" "On"
        Option  "AccelMethod" "exa"
        Option "ExaScratchSize" "8192"
        Option "MaxDRIMem" "16384"
        Option "MigrationHeuristic" "greedy"

^^ these lines must be there.
Ur DRI should've been enabled.
If u dont see yum installed or not here.U have to remove those :

:~#rpm      -e mesa-libGL-devel-6.5.1-9.fc6.i386
:~#rpm    -e  mesa-libGLU-devel-6.5.1-9.fc6.i386

Now try again.
if it fails showing some other deps,then download and install:
also dont use wildcards(*) while installing mesa from the link earlier i gave.just in terminal press TAB key will complete the rpm name if terminal is opened in the correct location.for eg: cd /home/user

jmikeneedham 05-03-2007 04:20 PM


Finally got the packages installed, tried to configure the X server exactly as you have it pointed out and I get that the X server cannot start with no specific errors but it eventually asks me if I would like the system to try to configure the server and upon my saying yes, I am back to the plain vanilla VESA driver.

I think that we need to find a good example of the P4M890 chipset Xorg config to figure this out. However, I am copying the log file here for hopeful help on getting this thing running!

BTW: The Yum Repo did work!


(II) Module mouse: vendor="X.Org Foundation"
        compiled for 7.1.1, module version = 1.1.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.6
(II) VIA: driver for VIA chipsets: CLE266, KM400/KN400, K8M800,
        PM800/PM880/CN400, VM800
(II) Primary Device is: PCI 01:00:0
(EE) No devices detected.

Fatal server error:
no screens found

It looks like the driver loads and then dies to me. This is the output from the Xorg.0.log.old

The current VESA driver of course loads no problem.


Getting help to get the X server configured properly is greatly appreciated, so if anyone has ever worked with this exact Unichrome Pro chipset or my Motherboard which again is an ABIT IP-95. Please post your Xorg.conf or pmail me and I can give you my email to see if it will work on my system.


BTW: The Monitor is a Dell M782 17", if we should maybe specify this in the Xorg configuration as well? I am not sure of the Horizontal and Vertical Sync rates, but I think I know where to find them :-)

deepclutch 05-04-2007 01:40 AM

Via cards are only supported in openchrome drivers.what i did was i compiled and installed subversion trunk of openchrome driver.
U can try it,though u r warned that u need many a dependencies like x11proto development files etc.

jmikeneedham 05-04-2007 10:26 AM


It is a via chipset and the driver just does not load the way you posted the Xorg.conf.

I suspect, that it is a matter of that my chipset being newer than the others, we are needing to get something in options or whatever... after all, it is a PCI Express motherboard and it tried to come up better than it did before, but alas, there is something we are not configuring to the P4M890's liking.

I really don't wish to buy a whole new video card just so I can use MythTV and all that :-/ This is the *only* reason I even care about getting the VIA drivers working.


The question still stands. I believe that we need to configure the XORG server to use this. Deepclutch's config does not work on my system. Any help is appreciated.

The OpenChrome drivers are installed, and now we just need to get the X server to *see* the card and run the monitor. I would like to configure the monitor as well.

The Monitor is a Dell M782 and has a Horizontal Sync range of 30-85 Khz and Vertical Sync range of 50-160 Hz.

The Video chipset is the VIA Unichrome Pro P4M890.

My current XORG configuration looks like this:


# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier    "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1024x768" "800x600" "640x480"

It is what FC6 autoconfigures the system to, so far any deviation from this config and we get no dice.

deepclutch 05-04-2007 02:51 PM

The message for my p4m800pro card is that it is CN700 something like detected.Ur card may be supported.the rpm u installed is almost 2 months old.Now for the bleeding edge versions of openchrome drivers are available from subversion repositories;which most possibly supports ur card.for that only i
gave the link
and refer OPenchrome wiki.
For this to work,U need to install some packages in ur Fedora that includes development files :(the packages with x11proto and some packages with (-dev) )
above all u need to install subversion.for that "yum -y install subversion" will do as i suppose u got yum installed.
refere below links:

U can join the mailing list @ openchrome.I feel this card (is)can be supported.
see the h/w supported:
Also check forums linux arena area for more help as Unichrome Open SOurce devels are there.

All times are GMT -5. The time now is 08:56 AM.