LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora - Installation (https://www.linuxquestions.org/questions/fedora-installation-39/)
-   -   Problems Installing Fedora on nvRAID (https://www.linuxquestions.org/questions/fedora-installation-39/problems-installing-fedora-on-nvraid-479006/)

ciaran_skye 08-31-2006 02:13 AM

Problems Installing Fedora on nvRAID
 
I recently bought a pair of Western Digital SATA 3.0GB/s drives to replace the original pair of Seagate SATA 1.5GB/s drives in a RAID0 configuration on an ASUS A8N-SLI motherboard. Both sets of drives are a pair of 250GB drives put into a RAID 0 using the nvRAID. I arranged the RAID0 as a pair of striped drives of 465.77GB each.

I installed Windows on the new drives for gaming, however when I went to install FC5 x86_64 on the old set it would load X, flicker, then stop with an "X" for the mouse on a black screen. When I used the text install it did the same except for stopping on a solid blue screen.

My previous experience with FC5 was nearly flawless on install, though the RAID broke after a Kernel update.

punker22 09-04-2006 06:08 AM

when you get the blue screen, it's not actually frozen, if you hit ALT+F2 you can get a command prompt which you can type 'top' to see what it's doing, you can also hit ALT+F3 or ALT+F4 for additional info. Sounds like it's having fun trying to find the correct drivers for the raid setup, I actually had a buddy run into this issue tonight ;) , if you can locate some linux drivers for your raid controller, do a 'linux dd' from the install CD prompt and load the drivers that may help it along :-)

-Scott

ciaran_skye 09-04-2006 08:06 AM

I had Fedora install on it in a RAID set up before and it went fine, but only with one pair of drives. Apparently Fedora is the only distro that supports nvRAID as far as I've found.

Might it just be more prudent to wait for FC6 in a couple months with a newer Kernel rather than get FC5 working?

punker22 09-04-2006 03:37 PM

remove all your drive arrays and re-initialize them, that fixed my friends problem.

-S

ciaran_skye 09-04-2006 04:33 PM

What do you mean by reinitialize? Do you mean to use the nvRAID set up and remove the drives then set them back up? I'd rather not have to reinstall Windows yet again if it kills the drives.

I pressed Alt-F3 and saw a warning that said Anaconda is using a depreciated SCSI ioctrl and to use sg_io. Could that be a part of the problem?

punker22 09-04-2006 06:02 PM

While I have never personally had this problem, my buddy did last night, he destroyed the arrays and rebuilt them and vwalla everything went swimmingly.

-S

evaso198 09-27-2006 02:52 PM

Hello! My computer is like as yours with installed Windows XP and the hard disks are exactly alike as yours set up raid0 on gforce. I want set up Fedora keeping Windows. If you have understood how set up both operating systems, can you explain to me how I can install fedora without destroy windows? thanks a lot

Bloater 09-29-2006 05:54 PM

I am also suffering with an identical problem, two RAID 0 arrays on the nVidia RAID controller of my MSI Diamond SLI mobo. Installed Windows XP & Windows XP x64 dual boot on the first pair of discs two SATAII in striped RAID. Then tried to install FC5 on second pair of discs two SATAI in striped RAID, it gets to the same black screen with a big white outline X then sits there forever I assume. I have also tried using the latest FC6 Test3 same again. It is really annoying not been able to have Linux on the same system. I now understand why people are happy to stick with Windows and forget about Linux, installation is a nightmare.:mad:


All times are GMT -5. The time now is 11:42 AM.