-   Fedora - Installation (
-   -   Problem upgrading F12 to F15 with PreUpgrade (

Cager 05-29-2011 05:10 AM

Problem upgrading F12 to F15 with PreUpgrade
Hi All. I am trying to upgrade my F12 system to F15 using PreUpgrade. The first stage seems to go OK and I get a message box saying it is ready to ugrade and to do a reboot.However it just reboots into F12.

PreUpgrade has added an"upgrade" folder to "/boot" and it contains upgrade versions of vmlinuz and initrd.I have tried running these from a GRUB command line but I get a "Error15 -File not found" error message. I realise that the upgrade is a long jump but the PreUpgrade info. on the Fedora site seems to suggest that this should be possible.Has anyone done this upgrade or have any ideas as to which file it can't find.

In case it is significant, during the initial preparation download the progress indicator doesn't get past about 10% and the progress arrow doesn't move below "Download Installer Images" in spite of which it says it is ready to upgrade.

Cheers Cager

smoker 05-29-2011 06:48 AM

Firstly check the grub menu when booting. There should now be an upgrade option.
Secondly, the default boot partition size has increased since F12. You need a boot partition of 500MB to download the upgrade files.

Thirdly, F15 is a completely different experience to F12. I suggest you use a live cd first before you commit to F15.

Cager 06-02-2011 01:21 PM

Hi Smoker. Thanks for the reply. I am somewhat puzzled as the documentation on the PreUpgrade facility says that if there is insufficient space in /boot it will be flagged when running the initial download and offer alternative ways of proceding. This did not happen and it then said it had finished and invited me to reboot to continue with the upgrade.In fact "df" says I have 44M available on /boot even after this. I have tried running a live version of f15 and it seems to work as expected on my hardware. However since the machine has two spare 250G drives I think I may just leave F12 as it is and set up a fresh install of F15 on these with one LVG for "/"and "swap" one LVG for "home" and a separate "boot" partition.
Cheers Cager

smoker 06-02-2011 05:36 PM

a) fedora resort to the dark arts, and upgrades are symptomatic.

b) F15 uses grub 2 by default. Are you confident that it will allow you access to your other install ?

frieza 06-02-2011 06:14 PM

you could also try doing a 'live upgrade'
yum update yum
yum update rpm
yum clean all
yum --releasever=15 distro-sync

there may be a few hiccups after doing this but it worked for me (though i only jumped from F14)

note, once the download has finished and the actual install process begins, do not --under any circumstances-- interrupt the update/install process, it could FUBAR your system to the point where the only option is to wipe and re-install from an install disk

i myself have had better luck with this method then the preupgrade option (last time I ran preupgrade i did FUBAR my system somehow)

All times are GMT -5. The time now is 02:27 PM.