-   Fedora - Installation (
-   -   no cd or usb bootability, need floppy to cd boot (

Person_1873 11-02-2007 03:21 AM

no cd or usb bootability, need floppy to cd boot
im in a bit of a pickle, i've recently blown my ide bus, i got a pci to ide expansion card that'll boot hdd but not cd, my usb bus is also blown from a power surge and a usb modem, my only possible boot method is to boot from floppy, could someone please point me to a boot image like debians so i can boot from floppy and install from cd, (i'm on a sony psp atm but have access to an fc6 box with a floppy drive

keratos 11-02-2007 03:43 AM

My god! Why dont you just buy a new motherboard. Pennies!

What do you intend to do with this pile of crap once, IF, you get anything onto it?

How good is this IDE controller card. Does it have UDMA6/7 mode (ATA-100/133) and all that? If not your disk performance might be poor.

A cheap n cheerful new motherboard with all the "stuff" on can be bought here for 30 to 40 GBP. Not sure where you are?

Anyway, here is a link that describes a process, from Windows or Linux, for CDs and Floppies. It also has links to floppy boot images albeit not Debian. It doesnt matter thats its Debian really, does it!

Take you pick!

Person_1873 11-02-2007 04:07 AM

thanks, im 16 (still dependent on my folks) and yes the card is a promise ultra100 it has ultra ata capabilities, i also have a usb 2.0 pci card, i'm looking into a new mb, just need a box to do so lol

keratos 11-02-2007 04:34 AM

Ah, 16, well you are certainly a brave young lad venturing into Linux at 16. Blimey when I was 16 I had a Sinclair ZX80 with 0.5K *yes half a Kilobyte* user RAM. It cost 199 in 1980 !!

Well, apologies to you, I was not aware you were dependant on financial gifts from your mom + pop.

Okay, well all I can suggest is that you try my link above.

What does concern me though is that you cannot boot from CD. Your card has a BIOS which should detect and boot from CD media. In your BIOS, is the CD detected in the HDD detection screen and is the BOOT priority in your BIOS set to CD THEN HDD ??

Even if you boot from floppy, you may find you still cannot boot from CD if the CD is not being recognised by the BIOS. If the BIOS cannot see it, I doubt whether Linux can.

You need to see if you can get it to see your CD and if you can, then it should be bootable.

No offence, but do you know how to do this? If not tell me what BIOS and version you have.

keratos 11-02-2007 04:42 AM


Correction! My colleague at work runs a Pioneer DVDR200 CD/DVD writer of his ultra 100 tx2 but her believes the controller may not have the "el-torito" bootable firmware in it.

This means it cant boot CDs but can read/write to them as a "normal drive".

You could try and upgrade the controller's BIOS using a windows machine.

First, I would try the link above, create a floppy, and see if you can boot linux and access the CDROM device.

Try the link above, boot and come back if you get stuck.

Person_1873 11-02-2007 05:00 AM

ok to make myself clear, i know what i'm doing, i've been doing this stuff since i was 5, i can see my dvd drive, i can boot from hdd, the only thing i don't know how to do is boot from the dvd drive, i have fc6 cd's, my mb bios is a bit useless for boot sequencing because it can't detect anything ide, the only way i can think of to boot a cd is to use a boot disk or access the bios of the pci card on boot, i tried the afore mentioned disk image but its for red hat and not fedora.

Person_1873 11-02-2007 05:11 AM

i've even tried changing my dvd drive to master on ide1 but it will only boot my 160gb seagate formerly maxtor hdd even if it's at the bottom of the cable hirachy

Person_1873 11-02-2007 05:20 AM

im thinking i should post this under hardware

Person_1873 11-02-2007 05:44 AM

*sigh* looks like there's 2 solutions to my greif,
1. mutilate my dads pci-ide card like this=
2. buy a new mb

keratos 11-02-2007 05:44 AM

If you know what you are doing then how come you dont know Fedora is the *free* derivative of Red Hat.

The Red Hat boot disk is fine. All you are trying to do it boot linux. ANY linux boot disk would do.

You said your BIOS does not support booting anything IDE ?? WHAT?? Are you sure. If your BIOS does not support booting CD or cannot see your promise card as bootable, you will never be able to boot from CD. But you of course know that dont you ;)

You MUST set your BIOS first and get it to either boot from CD or recognise your bootable Promise card. You MUST do this first.

Person_1873 11-02-2007 05:55 AM

my card boots my hdd, i've got that far, i can see my dvd drive, fedora may be derived from red hat, but that doesn't mean they can or will use the same boot media, i tried that boot disk you so kindly pointed me to but it didn't work with my fedora disks (yes it found them). fedora has developed for so long independant of red hat that they only share a kernel like most linux distro's, i think i might try that small linux distro thing, i'm sure i could install that off floppies

keratos 11-02-2007 05:58 AM

It does not matter whether the boot disk is FC, RH, Debian, or whatever.

The boot disk just gets you going. It should drop you into LiLo or GRUB. From there, you can setup a load of kernel from the CDs and boot the CDs.

This is EXACTLY what GRUB is for.

If the floppy image I gave you saw the CDs then you are on a winner. You just need to supply the corerct parameters to Grub/Lilo and boot the FC6 kernel off the appropriate root fs (on CD).

I'm not sure I understand what your problem is?

Person_1873 11-02-2007 05:59 AM

my mb ide bus is blown, my mb bios sees no ide devices, my pci card takes over after the dmi check, my mb bios can only tell it to boot from floppy

keratos 11-02-2007 06:03 AM

Okay. So you will never be able to boot from CD.

Person_1873 11-02-2007 06:05 AM

the boot disk is not a boot loader its a red hat rescue/install disk, it asks if you want to install from cd nfs ftp http or hdd, nothing else.

i now see what you were trying to point me to and i thank you, i'll look for a floppy bootloader that can boot cd's

All times are GMT -5. The time now is 06:43 PM.