-   Fedora - Installation (
-   -   new Fedora 7 installation will not boot -- kernel panic (

astrieanna 08-26-2007 02:28 PM

new Fedora 7 installation will not boot -- kernel panic
I just installed Fedora 7 from a DVD (which worked fine on another computer).

When the computer attempted to boot it gave a "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)".

There are two harddrives -- one with Fedora 7, the other with windows.

I'm not sure what to do as it seems to be looking in the correct place for the root fs and I haven't found a similar situation else where yet.

Any help would be appreciated.

MensaWater 08-26-2007 04:11 PM

Are the two computers identical hardware? If not then F7 working on one doesn't mean it will work on the other. Some older array controllers for example don't work properly with the default driver in 2.6 kernels found on FC4 and higher. There are ways to make it work (e.g. there is another driver than be loaded for the above mentioned array controllers) but you'd have to specify what your hardware config is.

Machine type
Processor type
Controller type

astrieanna 08-26-2007 09:45 PM

It has a:

AMD Athon processor
SOYO Motherboard
Adaptec AHA-2940U2W SCSI controller
Seagate ST39173LW harddrive (9 GB)

The DVD is atleast good since it worked on the other computer, which is completely different in hardware.

kjuergen 08-26-2007 10:47 PM

don't know whether it's related but I had severe problems with the Adaptec AHA-2940U2W. Sometimes it worked but most of the time not. Wasn't a hardware issue as older Linux's worked fine. I didn't investigate a lot as the HDD was old (= low capacity) so I replaced it with IDE's and SATA's.


MensaWater 08-27-2007 07:49 AM

Haven't done it on F7 yet but these notes from FC6 may help:

After you boot install disc type and get "boot:" prompt type
"linux noprobe" and hit return.

Select keyboard and language as usual.

You'll be given a box to pick driver. This will have all the drivers available. On FC6 there were at least 3 Adaptec drivers (including AIC7xxx the most common one). Make sure you pick the one most appropriate for your controller.

odcheck 08-27-2007 08:18 AM

check your grub.conf regarding root and initrd
The error says that it could load a Filesystem.

All times are GMT -5. The time now is 11:31 AM.