-   Fedora - Installation (
-   -   Missing gcc or wrong version (

NoobVer.01 08-18-2005 07:46 AM

Missing gcc or wrong version
Hey everyone, this is my first post.
Im running a amd64 939, and fedora core4(complete install), any other relevant details can be provided upon request but didnt seem important at this time.

I recently threw myself head first back into the deep (penguiny) end of computing, bought a new pc, and installed linux. (fedora 4, from PC Worlds Minibooks linux handbook) yay! first thing i did after making sure my net internet connection worked (yeah, it was christmas in july :P
First thing i tried to do was the check red hat network notification tool (up2date) for any available updates, started clicking the updates for the packages i'd installed the first time round and when the auto-installer, chose for them to be installed automaticly and promptly received a error message saying that the 'gcc' <version blah> could not be found

i gave it the benifit of the doubt, and because i had a bit of spare time up my sleeve i started afresh and did a "complete" install, all of everything on the 4 discs. started the up2date process again and got exactly the same problem.

dicided this time around, i'd play around, get used to Consolling Stuff and make a kickstart file for next time around with the programs and packages i ended up using

Started dwnloading programs (in rpm form) to install and got version errors on gcc when i tried to install them...

could the two problems be related? could it be a problem with this particular dist of fedora i got with the minibooklet? is there a way i can check either? or download a new copy of gcc+libraries?

also have problems downloading the macromedia flash plugin (with the on-screen link when mozilla cant display a flash image). i just receive a "install failed" "would you like to install manually" which im far from confident with, especially if using gcc is a requirement

any help+patience will be greatly appretiated


p.s. came back to edit this in after reading floppywhopper's post about including full sys specs and version numbers and my location, only problem is i cant find where to change my profile, if someone could email me, or a moderator could email me the details? that'd be great. thanks again

dugas 08-19-2005 02:00 AM

To check version of gcc
gcc -dumpversion
You can also see what rpms you have installed for gcc
Log in as root:
enter password
rpm -qa gcc*
You might want to use yum to update your machine, as root
yum update
yum install <package name>
Hope this helps.

All times are GMT -5. The time now is 11:50 PM.