-   Fedora - Installation (
-   -   installing SONY DVD RW DRU-710A on fedora core 3 (

pankajgadhari 03-17-2005 06:29 AM

installing SONY DVD RW DRU-710A on fedora core 3
hello friends, pankaj here, i am new to this forum
i want a step by step guide of how to install dvd+rw on fedore core 3. i have tried much of the things but i am not able to do that. so plz any body from the forum can help me for that.
Plz tell me the procedure frm the scratch
my dvd-writer drive is SONY DVD RW DRU-710A, ATAPI CD/DVD-ROM drive
and it is connected to /dev/hda.
Do i need to do the scsi emulation in Fedora core 3.
its very urgent
thanks in advance.

pankaj gadhari

WhatsHisName 03-17-2005 06:00 PM

pankajgadhari: FC3 will normally detect and make an attempt to configure new hardware on the first boot.

What happened when you booted? As a note, it is possible that you might need to “approve” the addition of the hardware configuration, but usually it goes automatically. I have not tried to configure a dvd writer, but dvd players and CD-RWs are picked up without any problems.

Did you get any functionality, even if it was only as a CD player? It would be helpful to see how it was configured in /etc/fstab. If my question is not clear, just list everything that is in /etc/fstab.

When you open the “computer” icon on the desktop, is the dvd writer present and what was it called?

One hardware note: If you got no functionality, be sure that your master/slave jumpers are set correctly and that /dev/hda and /dev/hdb are not both set to master or both set to slave.

pankajgadhari 03-17-2005 10:35 PM

thanks for ur reply friend,
bt i want to know that whether in fedora, scsi emulation is required for dvd-writer. I have done the scsi emulation, but i am able to write image using growisofs by giving command:
"growisofs -Z /dev/dvd -R -J /var"
it shows that files are written on DVD, but when i try to mount it, it is not showing any activity nor mounting the DVD.
now i am confused that whether DVD is written or not
my fstab file is like this :

/ ext3 defaults 1 1
LABEL=/SysHtml /SysHtml ext3 defaults 1 2
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/usr/local /usr/local ext3 defaults 1 2
LABEL=/usrHtml /usrHtml ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
LABEL=/var/lib/pgsql /var/lib/pgsql ext3 defaults 1 2
LABEL=SWAP-sda8 swap swap defaults 0 0
/dev/hda /media/cdrecorder auto pamconsole,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0

my device name is /dev/hda, after scsi emulation it was showing two options :-
/dev/dvd & /dev/dvdwriter, which one to choose ?
thanks for ur reply

WhatsHisName 03-17-2005 11:49 PM

To SCSI or not to SCSI, that is the question.....
There is a lot of discussion in this forum about dvd writers and I am not sure anyone has a good answer regarding a universal configuration.

Since it mounted as /dev/hda, you could just proceed as non-SCSI and use a fstab entry something like:

/dev/hda /media/dvd iso9660 noauto,user,rw 0 0

where you probably need to mkdir /media/dvd before rebooting. It is not clear to me that this makes the dvd writable, since “dvd” and “rw” would seem to be an incompatible combo.

Since you seem to have SCSI working and have the symlinks /dev/dvd and /dev/dvdwriter working, it would probably be worth trying:

/dev/dvdwriter /media/dvdwriter iso9660 noauto,user,rw 0 0 #or maybe ro instead of rw

where you probably need to mkdir /media/dvdwriter before rebooting.

One thing I have found with the FC3 media autoconfiguration is that you can often give it something that isn’t quite right and it will fix in after a reboot or two.

Regarding burning the dvd, look into “dvdrecord”, which seems to need a number of options to work properly.

WhatsHisName 03-18-2005 09:44 AM

And now for something completely different...
Here is another idea for you. Go fully automatic and try directly using the media autoconfiguration (fstab-sync) by modifying /etc/fstab like this:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/hda /media/dvdwriter auto pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

OR using the symlink

/dev/dvdwriter /media/dvdwriter auto pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

where "/dev/...,managed 0 0" is one line.

As before, be sure to mkdir /media/dvdwriter before rebooting.

When you get this to work, be sure to post the working fstab entry for future generations to use. This dvd writer stuff is not trivial.

pankajgadhari 03-20-2005 11:21 PM

i will try to do that.

All times are GMT -5. The time now is 08:53 AM.