-   Fedora - Installation (
-   -   Initializing hardware hangs after "yum update kernel-smp.x86_64" (

jandersonlee 03-14-2006 06:04 PM

Initializing hardware hangs after "yum update kernel-smp.x86_64"
I've some new, dual processor, SATA, Xeon/EM64T boxes that I'd like to try running with FC4. I can install FC4 from CD, but when I try to use yum to update, things go bonkers. It seems to be the new kernel that is causing the problems:

I (now) run a "minimal" config with:
kernel-smp.x86_64 2.6.11-1.1369_FC4 installed

When I tried "yum update", the update hung and I could not CTL-ALT-DEL reboot. When I reset, it hung at "Initializing hardware".

I then reinstalled and (after some experimenting) tried "yum -y kernel-smp". It installed/updated:
kernel-smp x86_64 2.6.15-1.1833_FC4 updates-released 16 M
Updating for dependencies:
module-init-tools x86_64 3.2-0.pre9.0.FC4.4 updates-released 407 k
udev x86_64 071-0.FC4.3 updates-released 1.6 M

After that when I rebooted, it once again hung on "Initializing hardware".

I can interrupt the grub auto reboot and boot up the old 2.6.11-1.1369_FC4smp version from the grub boot menu. That still works just fine.

My questions are: how can I fix things so that the latest kernel will work, or failing that, can I build a new kernel and inform yum so that it can the install any packages with dependencies on the newer kernel? If I add "exclude=kernel*" is yum smart enough to install updates on the packages that it can without failing on packages that require a newer kernel?



macemoneta 03-14-2006 09:39 PM

As FC4 is going to be superceded by FC5 in a few days, your best bet is to add the exclude line to yum (yes, it will behave correctly).

If the same thing happens under FC5, open a bug report.

All times are GMT -5. The time now is 08:09 AM.