-   Fedora - Installation (
-   -   Hanging on yum-updatesd (

rfleming 12-05-2006 02:14 PM

Hanging on yum-updatesd
Heya all,
I just installed my Fedora Core 6 on my primary computer as a duel boot. It seemed to install fine, but now when I go to load it for the first time it gets as far as "Starting console mouse service" If I have it show what it is doing the last thing it does is yum-updatesd. The progress spinner stops moving at this point. I still have control of the mouse and I i hit something on the keyboard it types into the details. This is my second install of this. Here are my computer's specs:
P4 HT 3.0
1 GB ram
Asus mobo(I forget the model number)

Any ideas on this one?
Thank you

gavster 12-22-2006 04:24 PM

Hanging on yum-updatesd
Yeh I have the same problem, installing fedora core 6 on my laptop (Advent 7055)
I thought it might be a problem with my touchpad but evidently not!
Its a 3.06GHz P4 CPU with 512MB RAM
Would a previous version (Core 5) work without this error? Am downloading it to try.
Was trying to install the KDE version, if that will make a difference.

snecklifter 12-22-2006 06:44 PM

Yum-updatesd is the daemon that checks for updates via yum, unsurprisingly. When Fedora boots, there is an option after the kernel loads to "Press 'I' for interactive startup". If you do this then select N for that pesky update service, you will at least be able to get to an GUI environment. You can then temporarily disable the service whilst you file a bug at :D


gavster 12-23-2006 03:29 PM

Yeh I tried that, but it seems to crash before I get to that service! tried changing the run level so that it would not load (using chkconfig) but that doesn't seem to help either.Seems to crash on rpcidmapd now, or if you say no to that service, it gets to pcscd(smart card deamon), albeit slowly.
Is there a way to do a software reboot if it crashes like that (ie rather than pressing the power button until the computer does a soft shutdown)?


snecklifter 12-24-2006 12:00 PM

Hmm. Can you get to run level 3?

You can do this by adding init 3 to the kernel boot options. Just enter GRUB and press e to edit the line.

Perhaps then you can start services individually and see which is really hanging. I'd certainly be inclined to file a bug on this one.


gavster 12-26-2006 07:44 AM

Which line do you add init 3 to? I tried adding it to the kernel/boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEl=/ rhgb quiet line and I got the following:

WARNING: can't access
exec of init () failed!!!: No such file or directory
Kernel Panic - not syncing: Attempted to kill init!

(Have reinstalled and unticked yumupdatesd in the installation options, but to no avail)

dishawjp 01-02-2007 09:47 AM

When you get to the grub splash screen, select your kernel, then type the letter "a" without the quotes. Then type the number "3" to enter runlevel 3. If you're still having troubles in init 3, you could also try booting using "single" instead of "3" This boots you to a root prompt with very limited services. Then use the chkconfig command (get more info on that if you need it using the "man chkconfig" command).



gavster 01-09-2007 04:19 PM

Thanks, I managed to get to run level 3 now, but it hangs on cups instead :(

There seem to be similar problems with sendmail:
Tried using "Single" too but as I'm a bit of a linux newbie I couldn't really achieve much!
Will keep endeavouring to get it to work, thanks for everybodies' help!

All times are GMT -5. The time now is 02:31 AM.