LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices


Reply
  Search this Thread
Old 02-02-2005, 12:24 PM   #1
xcraider
LQ Newbie
 
Registered: Jan 2005
Posts: 10

Rep: Reputation: 0
Angry Ghost menus and icons


When I installed Fedora Core 3 on my comp I had some problems with the screen blanking out. I thought that I had fixed all my problems by using the prompt "nofb". Now when I try to use ferdora I have numerous problems. When I open the applications menu I cannot see programs unless I scroll over them and they "appear". The my computer and home icons often disappear until I scroll over them. When I open up icons or programs the same thing happens or I get a mess of folders and items. I tried changing resolution and color depth but that did not change anything.

What's up???
 
Old 02-06-2005, 07:38 PM   #2
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Rep: Reputation: 15
Me too! Sorry not to be able to offer any help, unless two of us yelling might get more attention.

I have just installed Fedora Core 3 on a Compaq Presario desktop system with an 800 MHz Celeron processor. I don't know the video card, but I'll take a look if it might help. My monitor is a fairly generic low-end 1024x1280 LCD flat screen unit (marketed as "Envision").

All X Windows GUI widgets are screwy, typically remaining invisible unless I happen to float the cursor over them by chance. This applies to desktop icons, menus (as xcraider described), and any application windows that I manage to open (invisibly). If I can do something that forces them to redraw themselves, like dragging another invisible window across them, some components might appear, but it's not consistent across all window types.

Any ideas? This PC is essentially useless in this state, so thanks for any help. (I know I can use it in command-line mode, but this PC is for my wife, who is not Unix/Linux savvy, at least not with commands.)

- Bruce
 
Old 02-12-2005, 09:08 PM   #3
xcraider
LQ Newbie
 
Registered: Jan 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Follow-up

Bruce,

I heard that this problem might be related to a lack of RAM. But until I get around to ordering and installing some more, I won't know for sure.
 
Old 02-12-2005, 09:33 PM   #4
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Rep: Reputation: 15
Nope - I received a better explanation from the fedora-list mailing list. Apparently FC core 3 uses a version of X11 that is known to be broken when used with the intel 810 (and maybe other) video driver chipsets. Try looking at /etc/X11/xorg.conf and look for the "Device" section that mentions your videocard. If it mentions the intel 810, then that's your problem.

The best fix is to upgrade to the lastest build of X11 and see if the problem is fixed, but in the meantime, a good work-around is to add the line Option "NoAccel" to the videocard section of xorg.conf. That fixed it for me, and now it's running fine.

As soon as I've tackled some other problems, I'll try and update the entire system, but at least it works now.

- Bruce
 
Old 02-13-2005, 06:29 PM   #5
futseal04
LQ Newbie
 
Registered: Feb 2005
Posts: 14

Rep: Reputation: 0
I upgraded to the new X11 and it works just fine now. Of course, i had to do a lot of minimizing and maximizing of windows to see what i was updating, but I finally got it.
 
Old 02-13-2005, 08:27 PM   #6
xcraider
LQ Newbie
 
Registered: Jan 2005
Posts: 10

Original Poster
Rep: Reputation: 0
updating X11

Yeah, the videocard is an Intel 810 ( The machine is an IBM Netvista 6280)
This may be a dumb question but how do I update X11?
 
Old 02-13-2005, 09:48 PM   #7
futseal04
LQ Newbie
 
Registered: Feb 2005
Posts: 14

Rep: Reputation: 0
I did the Red Hat Updater (red circle with the white !). Click on it, and then move the cursor around to the bottom right, and click on "Launch up2date" At the red hat agent screen click on forward (again, move the cursor to the bottom right), and at the next screen, click on forward again. There will be a progress dialog box. When the next window comes up, maximize it. Start scrolling down, stopping every now and then to minimize and then restore the screen (this will refresh the screen, letting you know where you are. Towards the bottom you will see the X11 updates ( I think there were 4 or 5 of them). Click on those, and download them. you will have to keep an eye on them so that when they are done downloading, you can click on forward again to install them. After that, log out, and then log back in and all should be well.
 
Old 02-14-2005, 03:28 PM   #8
belliott4488
Member
 
Registered: Oct 2003
Location: Ellicott City, MD, US
Distribution: Fedora 11
Posts: 67

Rep: Reputation: 15
As a quick fix, you can add the line Option "NoAccel" to your /etc/X11/xorg.conf file, and then restart X (or just reboot). This will let you see your way around while you do your update.

I don't have the xorg.conf file in front of me, but I think it was as simple as finding the Device section for "Videocard" and then adding the Option "NoAccel" line. If you're comfortable doing command-line editing, you can just do Ctrl-Alt-F2 to get to a new virtual terminal and just do it there (that's what I did). If you look around in the xorg.conf file, you should see some examples of other Option entries, which will verify the correct syntax, in case I didn't remember it correctly.

Post a response if this doesn't work and I'll post a more detailed set of steps to follow.

Once you done your update, don't forget to remove the Option "NoAccel" line - you won't need it any more, and I assume that it's better not to have it.

- Bruce

Last edited by belliott4488; 02-14-2005 at 03:29 PM.
 
Old 02-20-2005, 09:11 AM   #9
xcraider
LQ Newbie
 
Registered: Jan 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks

I'll have to try this out. First I need to get Core 3 on my machine
(I've been using Core 1, it works fine.)

Thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Icons missing in user menus tomj54 Linux - Newbie 3 12-11-2005 10:23 AM
Changing icons on Gnome menus? timswim78 Linux - Software 3 07-31-2005 01:30 PM
too big icons and menus melihd Slackware 1 04-14-2005 04:20 PM
Abiword and how-to remove icons of the menus Grobsch Linux - Software 1 01-04-2005 03:22 PM
hiding icons in kde menus xconspirisist Linux - Software 3 10-18-2003 11:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation

All times are GMT -5. The time now is 09:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration