-   Fedora - Installation (
-   -   Fedora8 installed on Software Raid+lvm will not start (GRUB Hard Disk Error) (

nikaudio 07-07-2008 03:45 PM

Fedora8 installed on Software Raid+lvm will not start (GRUB Hard Disk Error)
I have Dell PE400sc with FastTrack SX150 tx2 Raid card. Two SATA drives are connected to it. Fedora would not recognize that RAID Hardware, so I have configured with anaconda software raid1: md0 with /boot partition (it is not on LVM), and md1 with LVM on it (logical volumes: / /home /usr /var /opt). After first booting I got error :
GRUB Hard Disk Error.

So I have run system in rescue Mode:
I could see all logical volumes mounted.

# chroot /mnt/sysimage
# grub
> root (hd0,0)
Filesystem type is ext2fs partition type 0xfd
> kernel /vmlinuz- ro root=/dev/VolGroup00/LogVol00
[Linux-bzImage, setup=0x2c00, size=0x1e0320]
> initrd /initrd-
Error 16: Inconsistent filesystem structure.

Please anybody with experience help.
Regards to you all.

nikaudio 07-08-2008 09:50 AM

After reading all HOWTO’s I could find, I have found a solution which worked for me:

# fdisk -l would returned Disk /dev/md0 does not have a valid partition table.

Started system from rescue disk,
# chroot /mnt/sysimage
# grub
grub > device (hd0) /dev/sda
grub > root (hd0,0)
grub > setup (hd0)

grub > device (hd1) /dev/sdb
grub > root (hd1,0)
grub > setup (hd1)

rebooted the system and it worked,
after a few days with Fedora installer I have noticed an lot of bungles, during customizing packages, anaconda installer crushed several times, finally I give it up I was not able to customize it. I had to proceed with default installation ! I have never have such a problems with Fedora5, RHEL4, and older RH.
Regards to you all

All times are GMT -5. The time now is 10:17 PM.