-   Fedora - Installation (
-   -   Fedora x86_64 not booting after installation on AMD 64 Athlon Presario r3140us Laptop (

rupak 04-25-2004 06:18 PM

Fedora x86_64 not booting after installation on AMD 64 Athlon Presario r3140us Laptop
Hi Everybody,

I have just bought the lovely looking Compaq Presario R3140US with AMD 64 Athlon. More specs are here and near the end of this post.

Got home, and downloaded the Fedora x86_64 distro as I want to use full 64 bit power of this box.

The Fedora installs fine though it can't detect the wide screen display (uses the 800X600 mode probably) and touchpad is fairly ok since I can click and move the pointers. (No scroll support though)

After everything installs cleanly, the reboot is ordered and I get the favourite GRUB screen.

When starting the Linux though, it goes very well upto the "Press I for interactive..." and probably couple of lines more and kernel panics :confused: :(

Can't get an image of panic as it scrolls very fast and I have no digital camera.

Everybody left disappointed and had to switchoff laptop manually.

It happens everytime... tried x86_serial_nr=1 from GRUB (grub says unsupported device when I enter this on commandline)

Any help, guys?

My dream of great 64 bit laptop with Linux and Eclipse is looking very cloudy... Atleast the 800x600 window should come, since it did come during installation.


PS: Here are the specs as promised.

Complete Specs:
Processor: AMD® Athlon™ 64 processor 3000+ (PowerNow!) 1.80GHz
Memory: 512MB DDR SDRAM (2 x 256MB) at 333MHz;
Graphics card: NVIDIA® GeForce4™ 420 Go with 32MB DDR (dedicated)
Hard drive: 60GB Enhanced IDE hard drive
Primary CD/DVD drive:DVD+R/RW/CD-RW combo drive
Display:15.4" WXGA TFT WVA (1280 x 800) display
Wireless connectivity: 54g Integrated 802.11 b/g wireless LAN
External ports: 3 Universal Serial Bus (USB) 2.0, 1 notebook expansion port
Communications: Integrated 10/100Base-T Ethernet LAN (RJ-45 connector), integrated V.90/V.92 56K modem (RJ-11 connector)
Sound: Internal speakers, JBL® Pro Performance, AC audio link, volume control button and mute button

crashmeister 04-26-2004 05:05 AM

You better get that thing to work - I plan on getting one of those :D
Here's what I found about it at a suse mailing list:

Your BIOS doesn't have a workaround for K8 erratum #93 and dropped the upper
32bits of the RIP. As a workaround boot with idle=poll and disable any
"USB legacy" options in the BIOS. Best is if you update your BIOS,
otherwise update then to the latest update kernel and remove the idle=poll
again. The update kernel will catch this exception, but still burn
more power. Best option is to get an fixed BIOS.

Might be your problem,might not.I did install gentoo 64 bit on an emachines laptop and that went fine except for the missing ati drivers - all the other 64 bit distro's I tried didn't go anywhere with it.
If you are comfortable with command line installs I'd try that route and bug the guys at the gentoo forums about problems - they are very good at solving them.They even made a special kernel for the emachines laptop back then.
The thing I normally do with new hardware is to stick a knoppix CD in there first.I now it's 32 bit but if knoppix doesn't boot you are in trouble and if it boots you can get a lot of info about the system that way.

rupak 04-26-2004 11:16 AM

Thanks for the reply.

Forgive my innocence, how to you get the BIOS update, if thats the issue? If that thing boots with "idle=poll" does it enough to say that BIOS needs fix.

Next, for knoppix CD, is it something I can download and burn?

I had been using Linux for about 8 yrs now... but this is the first time, I am trying it in 64 bit mode and on an expensive piece of hardware... Hence, I am very cautious to not spoil anything.


crashmeister 04-26-2004 04:12 PM

Don't know about that BIOS thing - got that from a suse mailing list.
I had to disable a whole shitload of things with the emachines AMD64 laptop to get it to boot nad finally got rid of it again because it has a ATI card that doesn't have any 64 bit video drivers available.

You can download knoppix and burn the CD from
Knoppix is a live CD that runs from RAM and has a real good hardware detection.If it doesn't boot with 'failsave' as parameter you are probably dead meat.You can't spoil anything with it since it doesn't install anything permanent.
As said I think your best bet is probably to go for a gentoo 64 bit install.People are very knowledgeable and helpful in the forum there.

rupak 04-27-2004 03:30 PM

Tried to boot single user from grub... same fedora x86_64 installation. Success. Mounted the fat32 partition so that I can get log files if anybody needs them. Need your help to go further. Just got error regarding some toshiba driver???

Tried startx and got the 800x600 screen. My touchpad is not properly working... only one particular directional movement is recognized ??? I'll try to fix the display with nvidia driver updates later. Do I need something else to get the full 1200x800 window?

I'll put in the knoppix CD later today to see the response. Will keep you posted on progress.

BTW, How do I attach log files to posts ?


rupak 04-27-2004 04:37 PM

Knoppix needs 700 MB CD and I have only 650 MB ones :(. So need to wait till I get a 700 MB one. I'm stuck pretty much with RedHat ones only.

crashmeister 04-27-2004 05:20 PM

The nvidia drivers should fix the display - you probably got a vesa driver running.If you installed redhat as 'laptop' (remember vaguely that there is such a option) it probably tries to load the 'toshiba laptop extras' or something like that - don't worry about it.Thats at the kernel level and if it boots you are fine to go regardless of error messages to get started.That thing about the CD's is unfortunate - normally you can take the xfree config file knoppix creates and paste it to your regular installation to get the touchpad and things like that going (eg. mouse and touchpad at the same time) - I know that I am lazy :-)
Nvidia drivers are not included with knoppix AFAIK but all you'll need to do then is to paste the knoppix config file for xfree and change the driver from probably 'vesa' or 'nv' to 'nvidia' yo be up and running.
Please let me know how you are doing or PM me - I am really interested in various facts about how this laptop is working out with a Linux 64 bit system - especially how redhat sets up a 32 bit system for the apps that don't work yet in 64 bit mode if they do that at all.

rupak 04-29-2004 11:35 AM

Another hurdle, nvidia drivers say kernel not supported. So need to download SRPMS to compile the driver.

I'm getting toshiba_acpi module errors. What does it do?

crashmeister 04-30-2004 05:06 AM

The thoshiba_acpi is in the kernel options as 'toshiba extras' and probably redhat has this compiled as a module which show that they are even bigger *&&^'s than I thought since there is no toshiba AMD64 laptop.If you kernel is a 2.6 (uname -a) you might need a patched driver from
I'd just recompile the kernel without the toshiba options and see what that does.

rupak 04-30-2004 08:46 PM

I plan to rebuild kernel over weekend if I get time off from beer parties :)

Anyway, I need kernel source for nvidia drivers. There is nothing better than brand new customized kernel. I had lot of kernel compile in 1996-97 when I has a Cyrix 486SX box with strange hardware. Good old fun :)

Wonder how would this effect my upgrade options?

rupak 05-01-2004 06:40 PM

system seems to boot ok now after passing acpi=off in command line. Surprisingly, the document from redhat suggests that acpi support is experimental and by default turned off?

The display is still an issue. NVidia driver compiled and installed. After several other steps, it now appears that I need to have modelines. Right now, my config does not have any modelines for display and that brings me a 800x600 centered window (rather used to bring, as I seem to have screwed somthing else now). Display sends EDID of 12800x800 that is ok but the drive ignores for missing modeline; so I see this now:

(II) NVIDIA(0): EDID reported maximum dimensions for display device DFP-0:
(II) NVIDIA(0): width : 1280
(II) NVIDIA(0): height : 800
(II) NVIDIA(0): Processing requested modes for display device DFP-0:
(II) NVIDIA(0): "1280x800"
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using mode "1280x800" (no mode of this name)
(II) NVIDIA(0): Not using mode "1024x768" (no mode of this name)
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz

How can I generate modelines from this EDID?
(II) NVIDIA(0): Supported additional Video Mode:
(II) NVIDIA(0): clock: 71.0 MHz Image Size: 331 x 207 mm
(II) NVIDIA(0): h_active: 1280 h_sync: 1328 h_sync_end 1360 h_blank_end 1440 h_border: 0
(II) NVIDIA(0): v_active: 800 v_sync: 802 v_sync_end 808 v_blanking: 823 v_border: 0
(II) NVIDIA(0): LTN154X1-L02

Also, i'm not seeing any messages in /var/log/messages since first day of installation? Where are kernel messages going?

Is there any way to boot knoppix of mounted image ? I just want to see if that can generate the config files :)

rupak 05-22-2004 05:11 AM

Well, the X now works. The touchpad remains an issue and I messed up something to get it working.

At this point, I think that there should be a hot key like "windows" key to start the fedora "start" menu. If somebody knows the keyboard shortcut to get that menu, that will be just great, since I have no mouse. :(

ps_sabu 10-19-2007 02:02 PM


Originally Posted by rupak (Post 947136)

At this point, I think that there should be a hot key like "windows" key to start the fedora "start" menu. If somebody knows the keyboard shortcut to get that menu, that will be just great, since I have no mouse. :(

Sorry mate. No such thing in linux.

rupak 10-20-2007 05:01 PM

I disagree. This is definitely possible to achieve - only a configuration issue. Just that there is no default for it out of the box.

BTW the thread is more than 3 years old.

All times are GMT -5. The time now is 02:38 AM.