-   Fedora - Installation (
-   -   Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768" (

suhaimi_sj 05-19-2004 07:13 AM

Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768"
Hi All,

Sorry about this dump question. This is my first time install Fedora Core 2 on my new laptop(OEM) Model CY27 same as from Compal but this one new model. Can some body advice me on how to change my laptop Screen Resolution from "800X600" to "1024X768" on Fedora Core 2. I have try to change it but there is no effect still "800X600" display.

Below is my hardware configuration that detect by WinXP on the laptop.
Display Adapter : Intel(R) 82852/82855 GM/GME Graphics Controller
DPI setting : 96
Monitor Type : Digital Flat Panel(1024x768)

Below is my xorg.conf configuration files that I have. Can some body help me. I want to MOVE from WinXP to FEDORA Linux. If the display cannot change I will not have the fun on surfing the net and do my daily work in peace. :(

Really appreciate your help


xorg.conf file:
# Xorg configuration created by system-config-display
Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 852"
VideoRam 65536

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666

jailbait 05-19-2004 06:07 PM

"Can some body advice me on how to change my laptop Screen Resolution from "800X600" to "1024X768" on Fedora Core 2."

One way to do this is to log in as root and run /usr/bin/redhat-config-xfree86.

Be prepared. Create a LifeBoat CD.

Steve Stites

suhaimi_sj 05-19-2004 07:58 PM

Hi Steve,

I have done this...but still no luck.

Any other advice.... really appreciate it


eXistance 05-21-2004 04:12 AM


I had the same problem when installing fedore on my laptop.
it didnt found my monitor and stayed at the 800x600 too.

i fixed this by installing fedore again, and at the bootprompt i did "linux resolution 1600x1200" and then i could also correctly select my monitor (LCD)

maybe this works for you too, let us know :)

tobysaville 05-25-2004 08:41 PM

fedora core 2 and 82852/82855 GM/GME
Sorry, but this is another question, instead of an answer.

I have been trying to get my 82852/82855 GM/GME display adapter working with fedora core 1, but cant even get X to boot.

I am curious that you seem to have gotten X to boot with this graphics controller. Was it easy to do with fedora core 2 or did you have to use 855wrap from


Da_Necromancer 05-29-2004 04:51 AM

about the resolution problem, its usually something to do with your refresh rate. xorg uses the information provided about your monitor in the xorg.conf file to determine 'safe' resolutions. if you are sure that your laptop lcd screen can handle a resolution of 1024x768 then its a simple case of xorg underestimating your monitor.

use your manual or maybe boot into windows (if possible) and find out the refresh rate the your lcd screens run at. (LCD's are locked to a single refresh rate and have an optimal resolution unlike CRT's and its usually 60Hz)

now to change your configuration.
since we're going to mess about with your display configuration, it would be wise to make a backup of things.
exit X and go into the plain black console.
cd /etc
cp inittab inittab.old (make a backup of inittab file)
edit the inittab file using vi or any other editor and change the default runlevel to 3 from 5.
save the file and exit.

(this ensures that should something happen to the display, you wouldn't have too much trouble reverting back)

cd /etc/X11
cp xorg.conf xorg.old
vi xorg.conf

go into the Monitor section and look at the refresh rate values.
currently they read
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0

using the info u got from windows or your manual, increase the horizsync and vertrefresh. please note that if the values are too high you won't have any display at all so please be careful.

since u changed the default run level to 3, the system will now boot directly into the console and not the familiar graphical login. so login and do a startx and try to get it to run on 1024x768. if in case you don't get any display... press CTRL+ALT+F1 and the hit CTRL+C to force X to shutdown. then edit your xorg.conf file again and reduce the refresh rate.

to revert back to your original config,
rename the inittab and xorg.conf files to something else or delete them
rename inittab.old to inittab and xorg.old to xorg.conf

(to rename use the mv command)

lonleyfedoraguy 05-30-2004 09:25 AM

I have a Dell Inspiron 1100 laptop and had the same problem last night (note my installation post). All I had to do was update my BIOS. You can find those at Username : Drivers Password: All.

vella 05-31-2004 01:03 AM

i'm very new to fedora core 2 /about 2 days/ and i had the same problem. it took me some time and also fear /when X wouldn't start/ but finally i fixed with changing values /increasing/ in sections:
ModelName "generic LCD"
HorizSync 40.0-60.5
VertRefresh 65.0-90.0

device: /it's the same vendor but differnt type of card/


Identifier "screen0"
device "videocard0"
monitor "monitor0"
Default depth 24
SubSection "display"
ViewPort 0 0
depth 256
modes "1280x1024"
SubSection "display"
modes "1280x1024" "1024x768" "800x600" "640x480"

it helped my laptop - twinhead efio 2BOO

nqnsome 06-07-2004 05:34 PM

Hi suhaimi_sj (and all the others),

I also have this Compal notebook (I guess it is a CY27, because this appears in the "drivers CD"), and I have the same problem!!!!! :( . I canīt say exactly the model, because the brazilian company the resells the notebook removed all the original identifying tags. It is a Celeron 2.2GHz, with a "Intel Corp. 82852/855GM Integrated Graphics Device". Here is the full lspci output:

[root@mynote root]# lspci
00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 02)
00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 03)00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 03)
02:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 02)
02:04.1 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 02)

Have you succeded in getting 1024x768 to work? After searching on the net for days, I found out that it seems that some versions of the 855GM vbios do not have all modes listed in it :confused: . For instance, in my notebook, Xorg claims that only the "800x600" and "640x480" modes are available. Probably, the Windows driver is able to bypass the vbios.

I have tried everything: Intel drivers, Xfree86 4.4.0, changing modelines, forcing modes, enable/disable DRI/Dual head, last version of kernel, etc., etc., and combinations! Nothing works! I also tried some utilities that I found on the net, that are supposed to replace a given mode by another:

They did not work for me, but maybe they will work for you.

Anyway, the best solution appears to be a BIOS update, to include the 1024x768 mode in vbios. The upgraded Vbios is available at Intel:

but, the producer of the notebook (Compal!) has to ship a BIOS update with the new vbios in it.

Did you get your notebook from Compal? Can you contact Compal?

Can someone contact Compal?

The BIOS setup utility says that the Bios is version "Phoenix Bios1.04".



caballeror 06-15-2004 10:56 AM

Changing the resolution in Fedora
I changed mine a lot eaiser than that. Of course you would have to be in the GUI (I'm running GNOME in 1280x1024)

I simply did the following:

I went to System Settings; then Display settings. Click the Hardware Tab and it will dispaly your Monitor Type as well as your Video Card. Select your Monitor Type and click configure and choose the type you want. That's it !!!

Hope it helps


suhaimi_sj 06-22-2004 12:22 AM

Hi "nqnsome"

Thank you for the advice. It 's seem that we are both having the same problem on the laptop Model C27.

Have you manage to update your laptop BIOS?

I'm in the middle of requesting the new update version of the BIOS from my laptop vendor.


ebrown27 06-22-2004 08:09 AM

Changing screen resolution
I had the same problem and as someone else previously stated, I easily corrected it by reinstalling Fedora Core 2 and setting the resolution to one higher than I wanted. After that I had 3 options on resolution, one higher, the one I wanted and one lower. I use both higher and lower to check my web pages in order to make sure that they are looking OK at other resolutions than I normally use.

Isn't Fedora Core 2 easy and slick to use. First thing that I have found that beats Mandrake.

nqnsome 07-01-2004 06:52 PM

Hi suhaimi_sj,

Sorry for the late answer. I did not realize that there were new posts.

I contacted COMPAL USA and after a few weeks (and some persistence) they answered. One of their engineers told that a new BIOS was released (1.06) with corrections, but could not say if the vbios was upgraded. I tryed that new bios, but the resolution problem remains. The US homepage is:

I sent a message to the engineer saying that the new BIOS did not solve the problem, but he did not reply yet.

Maybe you can try to contact him (by e-mail: jesse at bizcom-us dot com, or by phone, I donīt know if your are in the US), explain the problem and ask for the BIOS update. That would make us two complainers instead of one. It would be nice if you can contact your laptop vendor.

It useles to contact mine, because they do not even understand what is a "BIOS upgrade".

I also found another guy here in Brazil that has the same laptop.

Please, keep me updated.




Originally posted by suhaimi_sj
Hi "nqnsome"

Thank you for the advice. It 's seem that we are both having the same problem on the laptop Model C27.

Have you manage to update your laptop BIOS?

I'm in the middle of requesting the new update version of the BIOS from my laptop vendor.


newbiefed 01-13-2005 06:36 PM

I had the same problem
I was in the same situation and it turned out the solution was far easier than I had thought.

The setup I had:
PC running Fedora Core 2
ADI Microscan LCD monitor
Sis 6326 graphics card

Problem: the operating system would not allow me to select a screen resolution of 1024x768. Only two resolution settings were allowed-- these other settings made all the graphics too big to fit onto my display.

Solution: I found that by simply going to System Settings/Display from the desktop, then selecting the Hardware tab, and looking for the correct monitor from the list that matched your actual monitor, fixed the problem. Also, be sure you have the correct graphics adapter selected from the list. The operating system then instructs you to reboot for changes to take effect. Do it.
Then you will notice the next time you go to the screen resolution preferences, the drop-box list will auto-populate with more resolution settings to choose from, including 1024x768, and more refresh rates to choose from-- in this case, 75 MHz. Select those and then reboot again. That's it.

In my case, I did not have to edit the xorg.conf file which I had started to do. Choosing the appropriate monitor and graphics adapter in the control panel causes the file to be automatically edited for you. No mess. No fuss.

I was making it harder than it needed to be on myself.

Hope this helps.


cswor 01-21-2005 04:36 PM

thanks for that suggestion. i first thought it was the same one i had tried before which was to set resolution (it only gave 2: 640x480 and 800x600). but once i selected the hardware tab as opposed to trying to set the hardware type, it worked as you said. i haven't tried a reboot to see if it is going to stick around, but i'm betting it will.


All times are GMT -5. The time now is 03:58 AM.