LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Password
Fedora - Installation This forum is for the discussion of installation issues with Fedora.

Notices


Reply
  Search this Thread
Old 10-10-2004, 07:53 AM   #1
loconero
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
Fedora Core 2 grub problem


Hi,

I just installed Fendora Core 2 64-bit on a dual dual boot with Windows XP (which was already installed) to do this i resized my ntfs partition to 69GB with partition magic) so now 4 GB was left to install Fendora. When i start the installation i get the error "unable to align partition properly". I chose to ignore it, since the install said i could do so. The install went fine without problems, but when i have to restart the message GRUB pops up and couldnt do anything... I read of people who couldnt boot windows but i can't boot both windows and linux. What's my problem here?
 
Old 10-10-2004, 08:06 AM   #2
hitesh_linux
Member
 
Registered: Dec 2001
Location: /root
Distribution: FreeBSD,NETBSD,redhat
Posts: 472

Rep: Reputation: 30
It might be problem with NTFS. I would suggest you to create the free space and try install ing on free space. As you have less space to install Fedora core 2, during the installtion just create minimum partions like (/boot(100mb) swap(double of RAM size), / (allow all free space)

Hope this helps.

-/Hitesh
 
Old 10-11-2004, 02:57 PM   #3
faust_in_linux
LQ Newbie
 
Registered: Jun 2004
Location: brazil
Distribution: Mandriva2007Spring,FedoraC7, almost all time Debian and kurumin (le plus facile to newbies),
Posts: 19

Rep: Reputation: 0
There are some explanation about your possible problem hear:
http://www.linuxquestions.org/questi...hreadid=238796
http://lwn.net/Articles/86835/
I hope this help you
 
Old 10-12-2004, 06:36 PM   #4
loconero
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Well i got it working. I resized my winXP partition to 8 gb and after that the fedora stuff. I guess it may have been a problem with LBA or something. Weird though since i got a brand new motherboard (Asus K8NE). I could only select the auto detect option there.
 
Old 10-12-2004, 08:54 PM   #5
Zedd129
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Rep: Reputation: 0
I have this exact same problem except that I only have one hard drive. I have tried resizing the partitions as recommend above, but I have no linux experience and couldn't figure out how to do what faust recommended. I would be happy just to be able to boot to Windows. Please help ASAP.
 
Old 10-14-2004, 12:13 PM   #6
loconero
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Original Poster
Rep: Reputation: 0
i didnt repair it once linux messed up my MBR. The disk was new and had no important data on it, so what i did was boot from XP cd and install a new installation, then i deleted all the partitions and made a new one of 8gb. After that, windows worked again and I booted from Linux cd too install linux (warning! when creating auto partitions make sure to check the size of your root partition since you dont want too let linux take the rest of your drive space, do you? After that i had still a lot of unpartioned space on my hard drive which i configured in Windows XP as NTFS.

hope you could use this info, good luck!
 
Old 10-16-2004, 03:27 PM   #7
brainfry
LQ Newbie
 
Registered: Oct 2003
Location: Manchester UK
Distribution: Dapper 64
Posts: 25

Rep: Reputation: 15
I once had the same problem installing FC2. I've also had it with suse 9.1 both of which use the 2.6 kernel.

I ended up deleting every partition on the drive and starting again before finding a solution to my problem.

I checked the access mode for the drive in the BIOS and it was set to AUTO. Changing this to LBA before I re-installed FC2 fixed the problem, for me anyway. I also prepared some free space (about 21gb) using Disk Management under XP and during the FC2 install, I selected 'Keep all partitions and use existing free space' (or words to that effect)

Try checking your access mode like above and see if it helps.

Hope this info helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora core 4 with grub problem..won't boot TheDude05 Linux - General 5 08-16-2005 03:26 PM
GRUB Raid problem on Fedora Core 4 Flasher2 Linux - Hardware 0 06-26-2005 11:09 AM
Fedora Core 2 installation first boot problem with GRUB King-BoB Fedora - Installation 8 06-20-2005 06:05 AM
Problem w/ MBR, GRUB, Fedora Core 2 jmrich Linux - Newbie 4 10-08-2004 04:03 AM
[again...] GRUB problem on a Fedora Core 2/Win2k system Ghost Line Linux - Newbie 3 09-12-2004 11:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation

All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration