-   Fedora - Installation (
-   -   Fedora 4 Install not working AMD Athlon XP (

hellomajortom 11-08-2005 07:47 AM

Fedora 4 Install not working AMD Athlon XP
me ^

The answer to this may be really obvious, but can you put it simply for me? I decided to install Fedora 4, and went through the install program. I run Windows XP on my primary HDD, as I need it for school. On my second HDD I tried to install Fedora 4. I went through the entire install process doing what was recommended, and the install seemed to work fine. The computer rebooted and loaded up windows xp. I suspected something was wrong from not seeing GRUB, so I tried to get the BIOS to boot from the second HDD, but it said "Error in operating system". What can I do?


TruongAn 11-08-2005 10:22 AM

Please remember exactly where did you install GRUB on?
The Bios report OS problem on HDD2 so Grub is not on HDD2.
It must be on HDD1.
But Did you put grub in Master boot record or the first sector of linux partiton?
I think that you will have to reinstall grub?
But I cannot say anything definitely before you give the answer.

hellomajortom 11-09-2005 03:34 AM

I think originally I installed it on the MBR on HDD1. I reinstalled it again trying to fix it and opted to put GRUB on the first sector od linux partition (HDD2), but if i choose to boot from that harddrive i just get the text "GRUB" in the corner of the screen and nothing else.

TruongAn 11-09-2005 09:14 AM

So, grub used to be installed in MBR on HDD1 and it didn't work. Then you reinstalled in HDD2 and it show you the text GRUB in the corner of the screen, right?
Check if you are in the grub command line, you may be able to boot from this, can you type anythings?

hellomajortom 11-09-2005 10:03 PM

I can't type anything. It seems to freeze when it gets to the GRUB text.

TruongAn 11-10-2005 03:46 AM

Can you boot into windows now?

hellomajortom 11-10-2005 05:08 AM


TruongAn 11-10-2005 09:26 AM

It is so strange that I am afraid that I cannot suggest nothing except reinstall grub again into HDD1 MBR.
Sorry that I cannot help you!

dimitris.kalamaras 11-24-2005 05:26 AM

I see a pattern here and in other similar posts, i.e.

Many people trying to install FC4 on their secondary hard disk, using the auto-partition mode, get errors or simply can't boot fedora when installation finishes. Perhaps they did not setup grub correctly during install. Perhaps not.

As a matter of fact, a friend of mine has the exact same problem: On hda (which is PATA) he has WinXP and on hdb (which is SATA) he installed FC4 using auto-partition. When Fedora rebootted after install, Grub did not appear, Win XP did! We tried booting from the FC4 DVD > Rescue Mode, reached console, issued chroot /mnt/sysimage and then grub-install /dev/hda but the answer was something about missing driver of /dev/sd ??

The menu.lst was the following:
# grub.conf generated by anaconca
title Fedora Core (2.6.11-1.1369_FC4)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhg quiet
initrd /initrd-2.6.11-1.1369_FC4.img
title Other
rootnoverify (hd0,0)
chainloader +1

Does anybody know something about this problem? Could it be a bug?

All times are GMT -5. The time now is 04:41 AM.