LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora - Installation (https://www.linuxquestions.org/questions/fedora-installation-39/)
-   -   Fedora 32 upgrade via dnf resulted in functioning half-upgrade (https://www.linuxquestions.org/questions/fedora-installation-39/fedora-32-upgrade-via-dnf-resulted-in-functioning-half-upgrade-4175675833/)

rcx11 05-24-2020 07:04 PM

Fedora 32 upgrade via dnf resulted in functioning half-upgrade
 
I made the upgrade from Fedora 31 to 32 using 'dnf system-upgrade'. I've done successful upgrades with this before. Download and installation appeared to work fine. The system rebooted without trouble. To ensure the system was fully updated, I ran 'dnf update' only to find that it claimed module dnf did not exist. I did some tinkering and installed the Fedora 32 rpm, python, gpgme, and dnf packages via rpm. dnf function is restored; however, tries to install Fedora 31 packages. cat /etc/fedora-release output is "Fedora release 32 (Thirty Two)." My system continues to boot and function otherwise correctly, but I'm unable to make upgrades. I try to use 'dnf update --releasever=32 --allowerasing' but just yields conflicts between the installed fc31 packages and the desired fc32 packages. I'm about to start a quest to install the conflicting packages using rpm, but I'm hoping for some help "properly" correcting the issue. Thanks in advance.

syg00 05-24-2020 09:51 PM

Have a read of this.

rcx11 05-25-2020 11:09 AM

Thanks for the link. I'm progressing (I think), but still not resolved. After rebuilding the RPM database, dnf began properly referencing the Fedora 32 repositories. However, I'm still getting issues with the kernel. No other dependency issues are showing up like I saw before.

Code:

$ sudo dnf distro-sync --allowerasing
Error:
 Problem 1: package kernel-modules-extra-5.6.11-200.fc31.x86_64 requires kernel-uname-r = 5.6.11-200.fc31.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.6.11-200.fc31.x86_64 requires kernel-core-uname-r = 5.6.11-200.fc31.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)

Adding --skip-broken has no significant effect.

shruggy 05-25-2020 11:29 AM

What kernel are you running currently? The messages indicate a kernel from Fedora 31. Perhaps, reboot into a newly installed kernel, then try again?

rcx11 05-25-2020 03:26 PM

The kernel at the time was 5.6.13-200.fc31.x86_64. I realized that the kernel about which it was complaining was the previously installed and running kernel, to which I could still boot. I restarted to that to see if it would recognize that it was already running it. Now I get:
Code:

Problem: package kernel-modules-5.6.13-200.fc31.x86_64 requires kernel-uname-r = 5.6.13-200.fc31.x86_64, but none of the providers can be installed
  - conflicting requests

I'm thinking of trying to install an fc32 kernel package using rpm and see if that will force the swap over.

syg00 05-25-2020 05:43 PM

I have a somewhat sanguine view of package managers - they are a necessary evil. When they screw up upgrades I don't spend a lot of time trying to fix things. I simply re-install from scratch and then go get the packages I need - having a separate /home partition became a standard procedure years ago. Used to be every second version screwed up, but dnf has been much better.

rcx11 05-25-2020 11:50 PM

I think I've figured out how to make the repair. Since I'm now booted to the 5.6.11 kernel, I'm getting the errors for the 5.6.13 kernel. Based on the discussion from here, I manually uninstalled the 5.6.13 kernel and modules. This changed the nature of my errors to individual file conflicts. I ran 'dnf update --allowerasing' to get a list of the packages of the fc31 packages that required removal. It became removal of those packages individually, but I'm on the edge of completing the Fedora 32 installation and update. The packages are being install at this time.


All times are GMT -5. The time now is 06:44 PM.