-   Fedora - Installation (
-   -   FC9 Install Fail Please Help (

TrekStrong 11-14-2008 04:58 PM

FC9 Install Fail Please Help
Well this was a mistake for being too anxious to get FC9 on my server upgraded from FC5. I had initially installed FC10 Beta and selected to encrypt sda1 and sdb1. I decided after inatalling FC10 and browsing around that I wanted to reinstall FC9.

Before installing FC9 I destroyed my encryption passwords(passphrases)for FC10 Beta because I knew I would be reinstalling FC9 and creating new passwords.

Well, now I cannot reinstall FC9 because it is asking me for the passphrase for both of my drives. When I select cancel during the install it allows me to continure but later on towards the end the install fails.

How can I get around this???? Please!!!! Help!!!

unSpawn 11-15-2008 04:32 AM

I don't know what encryption is used in your F10 install, but if there's nothing of value on sda1 and sdb1 you could zero out those partitions. If there *is* valuable data then maybe using the F10 installer DVD might get you to the point where you could mount them and get your data off the drive or decrypt and disable encryption?..

TrekStrong 11-15-2008 11:44 AM

Thanks for your reply... This was a fresh install and there is zero data on both drives. I can wipe them both out totally. Forgive me, however I'm not sure what you mean or how I could zero out my partitions. I'm kind of more advanced than a newbie but not quite as advanced as a guru.

I tried to delete sda1 and a message popped up that said it could not be deleted because it belonged to VolGroup00 (the default setting). I was reading up on how partitions work on Linux with VolGroup, LV, etc, but I'm still not sure how to proceed securely so that I'm not deleting essential partitions or groups that keep my system stable.

Can you be a little more specific on what you mean about zero-ing out my partitions? I can do that, no problem. BTW I'm using GRUB as the boot loader and anaconda for the install.



unSpawn 11-15-2008 02:40 PM

The encryption in use is LUKS. The "disk" you use is a Logical Volume, which is "built" glueing several partitions together. As long as the partition is not a part of any existing and used LV then there should be no problem deleting it. There must be an easier, more efficient and probably graphical way to check the representation of LV's in use, but I don't use them tools and I don't use Fedora. The first thing I'd do is make sure both partitions *really* aren't used. Please scan your machine with '( fdisk -l; vgscan; pvscan; lvdisplay ) | tee /tmp/output.$$' and post the contents of the output file. If we know for sure then, as far as I know, "erasing" the LVM signature from both partitions should be enough (should look something like 'dd if=/dev/zero of=/dev/sda1 bs=512 count=4').

All times are GMT -5. The time now is 11:53 AM.