-   Fedora - Installation (
-   -   FC6 - Intel 945 - 1280x800 Resolution (

vsridhars 02-03-2007 06:56 AM

FC6 - Intel 945 - 1280x800 Resolution

On my Toshiba M500 Portege Laptop, it came with Intel 945 Chipset.
Now, default install - goes thru - screen comes up with 1024x768 :

I have tried manually tweaking xorg.conf, installed 915resolution and patched one of the displays to show 1280x800 et al.

However, this does not stick.

Screen-Config menu gives me a 1280x800 --> but on a reboot, if I see the xorg logs, it shows some detected modes, 1280x800 not a valid mode, some HSync and VSync out of detected ranges etc. I tried tweaking each one by one but am still not thru.

FC6 release notes recommended switching the display driver from i810 to intel.
Even that did not change things in a big way.



vsridhars 02-03-2007 09:10 AM

Got sorted out -

a) There was a new xorg patch that was rolled out a couple of hours ago. (had done a check and had no patches to install in the morning).

b) After installing the patch, checked my xorg. conf --> noticed 1280x800 was missing in modes --> and there were two entries for 1024x768.

c) xorg is now having these relevant sections:
Section "Device"
Identifier "Videocard0"
Driver "intel"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800" "1024x768"

d) This - in conjunction with the 915resolution patch (and its call in /etc/rc.d/rc.local -- to introduce the 1280x800 resolution against an existing unused conf.)

e) This setup is working now --> I am not sure if the 915resolution patch is required now with the updated xorg patch -- but after a lot of reboots in the last 2-3 days - finally after getting this working, do not want to fiddle with removing 915resolution for now.


All times are GMT -5. The time now is 05:44 PM.