-   Fedora - Installation (
-   -   FC3 installation fails at post install configuration stage (

grstaker 01-10-2005 10:54 AM

FC3 installation fails at post install configuration stage
I am trying to install FC3 on to my second hard drive but the post install configuration phase freezes half way through. This could in some way be related to the messages which come up as I start the installer from the first burnt CD:

"Disabling IRQ#5"
"irq5 : nobody cared! (screaming interrupt?)"
"try booting with acpi=off and report a bug"

I have tried what others have suggested in response to similar reports by setting boot options such as "noirqdebug", "irqpoll", "acpi=off" etc but the dreaded "Disabling IRQ#5" message persists on the screen until anaconda's graphical mode eventually cuts in.

The install session itself runs smoothly from then on as I fill in the usual details and select my preferred partitioning scheme on the second drive and for the sake of just getting a result I have selected minimal set of packages. So, the formatting runs fine, the packages are loaded but then the process grinds to a halt during the post install configuration stage.

Some information about my system:
Pentium 4 3.00 GHZ
512 MB RAM
ASUS P5P800 motherboard
2x 80G ATA disks (identical models)
IDE operating mode: Enhanced (S-ATA).
XP/SP2 loaded on 1st disk.

AMI BIOS 08.00.10 (1005.001)

IDE config
Primary IDE master WDC WD800BB - 23FJA0
Primary IDE slave Not Detected
Secondary IDE master HL-DT-ST DVDRAM GSA 4160B
Secondary IDE slave Not Detected
Third IDE master Not Detected
Fourth IDE master Not Detected

Is the IRQ#5 problem likely to be the cause of the installation failure and if so does the above information lend any clues as to how the problem may be remedied? I notice that this interrupt is not listed below:

IRQ 0 System timer OK
IRQ 1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK
IRQ 3 Communications Port (COM2) OK
IRQ 4 Communications Port (COM1) OK
IRQ 6 Standard floppy disk controller OK
IRQ 8 System CMOS/real time clock OK
IRQ 9 Microsoft ACPI-Compliant System OK
IRQ 10 MPU-401 Compatible MIDI Device OK
IRQ 12 Microsoft PS/2 Mouse OK
IRQ 13 Numeric data processor OK
IRQ 16 RADEON 9200 PRO Family (Microsoft Corporation) OK
IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24D2 OK
IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24DE OK
IRQ 17 SoundMAX Integrated Digital Audio OK
IRQ 18 Intel(R) 82801EB USB Universal Host Controller - 24D7 OK
IRQ 18 Intel(R) 82801EB Ultra ATA Storage Controllers OK
IRQ 19 Intel(R) 82801EB USB Universal Host Controller - 24D4 OK
IRQ 20 Agere Systems PCI Soft Modem OK
IRQ 22 Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller OK
IRQ 23 Intel(R) 82801EB USB2 Enhanced Host Controller - 24DD OK

grstaker 01-12-2005 07:54 AM

Solved it! Changed IDE mode from "enhanced" to "compatibilty".

bulitka 06-15-2005 08:08 AM

How do you change IDE mode from "enhanced" to "compatibilty"?

I am having the same problem that you described.

grstaker 06-17-2005 09:37 AM

I am referring to the onboard IDE operate mode which you can select from your BIOS setup. Enhanced Mode was the default setting in my system configuration, which is fine if I only wanted to run XP. I found that only by selecting Compatible Mode (the alternative) was I able to continue successfully with the installation and ultimately dual boot to FC3.

bulitka 06-17-2005 09:43 AM

Were you still able to run XP? I want to be able to dual-boot too (XP and Linux).

grstaker 06-17-2005 09:51 AM

Yes! No problem at all.

bulitka 06-17-2005 10:00 AM

Thanks folks. I'll try this out.

Could someone explain (i)what these two modes do and (ii) why enhanced mode would be generating screaming interrupts that Linux (at least FC3) couldn't deal with?

bulitka 06-19-2005 03:32 PM


I tried switching to Compatibility mode, but then my BIOS (ASUS P4P800, version 1019) did not give me the option of booting from my DVD. Any idea why this is?

grstaker 06-20-2005 10:43 AM

Further info on my configuration:

The 1st and 2nd hard disks are on the primary master and slave channels respectively and the DVD/CD drive is on the secondary master channel.
I also had to change the IDE port settings to reflect the fact that I have parallel ATA ports only (the default BIOS setting with Enhanced Mode is S-ATA).

Hope this helps.

All times are GMT -5. The time now is 06:17 PM.