-   Fedora - Installation (
-   -   FC3 installation error: partition has to be formatted (

ennar 04-11-2005 04:02 AM

FC3 installation error: partition has to be formatted
I'm trying to install Fedora Core 3 on my P4 desktop (has win XP already installed). I have a new 160Gb hard drive that I just installed and I would like to use part of this disk for linux. After the hard drive installation, I booted with Fedora Core 3 CD#1 and got through the initial screens, specified disk partitions (29Gb ext3 to be mounted as '/' and a 1Gb swap) and selected packages to be installed. And I see a msg indicating that the partitions are being formatted...

But right after this, I get an error msg pop up saying:

Error Mounting device /dev/hde1 as /:invalid Argument
This most likely means this partition has to be formatted
Press ok to reboot

If I reboot and get back to the installation screens, I get an error msg saying:
Unable to mount hde1

I have tried both the automatic partition and manual DiskDruid options ... same thing.

I then booted with the rescue CD and tried recreating a single linux partition (/dev/hde1) on the disk using sfdisk and created an ext2 fs on that partition using mke2fs. My theory was that the installation software would be happier with this. When I reboot again with CD#1, I no longer get the "Unable to mount hde1" error but I seem to end-up with the same "press ok to reboot" error.

Wondering if anyone has seen this before and any suggestions on what I might try next...


WhatsHisName 04-11-2005 10:52 AM

Is the new drive an SATA or PATA drive?

The /dev/hde1 message would seem to indicate that you are using a disk controller card. What is the controller card’s manufacturer and model number?

What do you have connected to your primary and secondary IDE channels?

Your problem sounds like a hardware/driver issue, hence the questions to clarify the hardware setup.

ennar 04-11-2005 11:29 AM

Its PATA (Ultra ATA/100). Seagate ST3160023A

I dont have a controller card but the MB (Abit TH7II) has an on-board RAID controller (HPT370 RAID controller. There are 4 IDE connectors on board). The new drive is connected to IDE3 connector (IDE3 and 4 connectors are controlled by the RAID controller) although I am not trying to really use it as a RAID device (is that possible?)

System is populated as follows:
IDE1 : Master/Slave Hard drives (master XP boot drive)
IDE2 : 2 CDROM drives
IDE3 : New hard drive (3rd one)


WhatsHisName 04-11-2005 11:57 AM

You are probably fighting a driver issue that may be difficult to overcome. The failure-to-mount error just screams “driver problem”.

At the motherboard BIOS level, is the new drive presented as a regular IDE device like the other hard drives or is it presented as some type of Raid drive?

BTW, a very simple way to get your system to work is to install a disk controller card that is supported in FC3 and install the drive on it. A Promise Ultra100 TX2 controller card ( would be a cheap and quick way to get going.

ennar 04-11-2005 12:28 PM

Its presented as a primary master by the HPT controller BIOS .. I guess that means its treating it as a RAID drive?

I'll look into the promise card ... thnx for the suggestion.

Since I need to get this drive installed and working rightaway, I think I am going to pull out the primary slave on IDE1 and put this one instead. I can try to restore the configuration later once I get the card or even get this setup working.. (by magic).

I guess I will have to reinstall the boot loader (grub) at that time (i.e. if I add the drive and/oro change drive order) since the BIOS drive numbers might change. Is there anything else I would have to worry about if I did that?

Thanks again for your help.

WhatsHisName 04-11-2005 01:11 PM

Yeah, you will need to reconfigure the Grub setup after you move the drive to a controller card. You can otherwise move the drive around without any problems (see below).

While you have FC3 running, make a Grub boot floppy as is described in the Grub manual ( in the “Creating a GRUB boot floppy” section. Then, after you put in the controller card and swap the drive to it, follow the section “Installing GRUB natively” by booting from the Grub boot floppy and then using the commands “find ...”, “root ...” and “setup ...” as are described in the manual.

Regarding swapping the FC3 drive around later, the way FC3 will set up the drives in /etc/fstab and in /boot/grub/grub.conf will use the “LABEL=” format to identify the partition(s) by name, as opposed to the “/dev/hdxy” format which points to specific devices. As long as the FC3 partition labels are not used by any other partitions in the system, you can put the FC3 drive anywhere that Grub can find it and FC3 will boot/run fine. Of course, the MBR Grub Stage1 loader does need to point to the correct boot partition, hence the reason for making the Grub boot floppy.

WhatsHisName 04-11-2005 01:29 PM

Oops, I just remembered that the swap partition is defined by device location in /etc/fstab, not as a label. So, you will need to change the definition when you move the drive.

The easiest way to change it is to do so before the last shutdown in the current location. The Promise primary/master should be /dev/hdg in your setup (4 IDE channels), whereas it would be /dev/hde with just two original IDE channels.

Otherwise, you could boot into linux rescue and edit /etc/fstab using the vi editor. The system would probably even boot with the swap incorrectly defined, but it’s been too long since I tried that to remember whether it works.

All times are GMT -5. The time now is 06:25 PM.