LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora - Installation (https://www.linuxquestions.org/questions/fedora-installation-39/)
-   -   Error Installing FD8 on Compaq 3200 RAID arrays (https://www.linuxquestions.org/questions/fedora-installation-39/error-installing-fd8-on-compaq-3200-raid-arrays-614017/)

hawkmeister 01-16-2008 11:10 AM

Error Installing FC8 on Compaq 3200 RAID arrays
 
Hi,

This is my first post to this Forum. I have worked with all flavors of Unix (mostly Solaris) for a fairly long time but I am pretty new to Linux.

I installed Fedora 8 on a laptop without a problem and have been using it for a while. I did a network (HTTP) install initially booting from the rescue disk since I do not have a DVD Burner to create an install DVD.

I recently decided to upgrade my Compaq DL580 server to Fedora 8 as well. This server has the Compaq 3200 RAID controller and is configured with three RAID 5's. One is composed of 4 18.2GB SCSI drives making CD0 a 51GB volume. The other two are F1 RAID chassis with 7 36.4GB drives making a 218GB volume and 8 18.2GB drives comprising a 127GB volume respectively.

My problem is:

I boot from the rescue disk and choose to install from an HTTP source.
I configure the eth0 interface.
I set up the filesystems as follows:

swap 4096
/boot 1000
/ the rest of the available space

I choose the items to install.
It formats the drives.
Immediately following the formatting, I get an error saying that it could not install the package, and that I am probably out of disk space.

I have tried everything including a minimal install. It apparently is not recognizing the space on the logical volumes but I have not idea why. I saw the previous threads talking about using the Smartstart CD. I originally created the LV's using the Smartstart CD and am not sure if I have to redo the configuration to install a new OS. Has anyone come across this problem before? Any advice? Can Fedora load onto a RAID or do I have to remove one of the drives from the array to give it a physical location to install. This is not desirable for obvious reasons. It is also a pain to do. Any advice would be greatly appreciated.

Thanks,

Rob

perryclark 02-04-2008 03:19 PM

FC8 on Proliant 5500
 
Hi,

I am also struggling with my Proliant 5500 with smart array 3200. I have configured the array(several times now) using the smart start tools for RAID 5. There are (7) 9.1GB drives in the array. There are (4) Intel 450Mhz 1mb cache Xeon CPU's installed. 1GB RAM.

Here's my problem... I'm booting from a Fedora 8 Live CD. Boots up fine, install process recognizes the array with the Compaq Diag partition properly, and creates the LVM below that. At first I did wonder if the array being configured in hardware and LVM would conflict, but I guess it doesn't (I also manually created the partitions during one other attempt... didn't seem to matter).

OK, so the install chugs along just fine, and then I reboot, get the grub prompt - At this point I think it has munged my Compaq Diag's partition - Hitting F10 at the compaq diag's prompt brings me right to Grub - even though I specifically installed the boot loader onto /boot, not the MBR - not sure why.
It gets to Grub, then goes to boot and gives me a switchroot: mount failed error. I have seen threads mentioning:

memmap=exactmap memmap=640K@0 memmap=960M@16M (if over 1GB ram)
also
noapci nousb and a few others, which haven't helped.

Have you found a solution? In the meantime, I'll keep hammering on it and let you know what I come up with.

Thanks,

Perry Clark
xTuple, LLC.

Update - 2/5/08:

Found this website: http://cho.hapgoods.com/wordpress/?cat=5&paged=2 . After reading some on here, I decided to install FC5. (FC5 rescue, http install) Install went fine, rebooted, and it booted up. Now, I need to get the SMP working (only seeing 1 CPU, not recognizing smp motherboard, see below..)

[pclark@localhost ~]$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 5
model name : Pentium II (Deschutes)
stepping : 3
cpu MHz : 449.935
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr
bogomips : 901.82

The smp kernel was installed...

Linux version 2.6.15-1.2054_FC5smp (bhcompile@hs20-bc1-3.build.redhat.com) (gcc version 4.1.0 20060304 (Red Hat 4.1.0-3)) #1 SMP Tue Mar 14 16:05:46 EST 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003fffc000 (usable)
BIOS-e820: 000000003fffc000 - 0000000040000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
127MB HIGHMEM available.
895MB LOWMEM available.

Hrumph....

Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Checking 'hlt' instruction... OK.
CPU0: Intel Pentium II (Deschutes) stepping 03
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Brought up 1 CPUs
0

Any ideas?


All times are GMT -5. The time now is 08:27 AM.