-   Fedora - Installation (
-   -   Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card (

nsyng 06-05-2005 11:46 AM

Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card
This really isn't an installation question, but anyway...

I have been running a dual-boot (FC3 and Win Xp) AMD machine having a single 120 Gb harddisk, ASUS motherboard, and on-board VIA Ethernet. The dual boot system was working fine till recently when my cable modem and the on-board Ethernet device stopped working after some storms in our area. The rest of the system was working fine, only network support was no-longer available.

Yesterday I added a D-Link PCI Ethernet card to my system, diasbled the on-board Ethernet and was successfully able to boot into XP and connect to the netwrok.

However, on rebooting the GRUB bootloader does not work and hangs after throwing up an error "GRUB Loading Stage2Read Error" as soon as I reboot. I do nto get the GRUB Menu (for selecting Linux or WinXP) and am unable to boot into my system.

I am able to boot to rescue and text modes using FC3 Installation CD.

I have unsuccessfully tried tinkering around to fix this problem in the following ways so far:
1) Linux Upgrade and reinstall (tried mutliple times to get a fresh GRUB installation). Tried installing both on to MBR and first sector of primary partition.
2) Changing BIOS setting for on-Board Ethernet from "diasbled" to "Auto". (Really, this is the only change I made during installing the PCI network card"
3) Changed BIOS IDE setting to enable DMA Access (based on some threads I found). Have reset it back to "Auto" since this did not help.

Unfortunately I do not have a WinXP installation or Recovery CD ready to fix Windows.

Can anyone help me with figuring out whats gone wrong with GRUB and how I can fix this... Any help is appreciated.

nsyng 06-06-2005 06:53 AM

Okay, I seem to have identified and fixed the problem, though I still do not know what was going wrong. Can somebody explain what was happening, and let me know if there is a better solution.

Basically, When I changed BIOS Setting "IDE to DMA Transfer Access" to Enabled, GRUB loaded properly and I could boot into WinXP or FC3 as normal.

However, on rebooting, the "IDE to DMA Transfer Access" BIOS setting would get reset to "Disabled" on its own, and I would run into "Grub Loading Stage2Read Error" once again. After a lot of trial and error I figured that if I Enable the on-board Ethernet (the one that doesn't work anymore), then "IDE to DMA Transfer Access" BIOS setting would stay "Enabled" instead of getting automatically reset to "Disabled" at reboot.

This doesnt seem to have anything to do with WinXp or FC3 Operating System, because the setting gets disabled even if I reboot at GRUB stage itself.

So now my comp is running fine with "IDE to DMA Transfer Access" and On-board Ethernet both set as "Enabled". If either gets disabled, I would once again start facing "GRUB Loading Stage2Read Error" messages!!

Can anyone help me understand what seems to be happening?


All times are GMT -5. The time now is 12:20 AM.