-   Fedora (
-   -   yum update results in python IndexError (

pattbert 06-17-2010 10:41 AM

yum update results in python IndexError

I haven't been able to update my system as of late, because yum keeps giving me the same error, everytime I try to run updates/install packages.


Running Transaction
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/", line 192, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/", line 496, in doTransaction
    resultobject = self.runTransaction(cb=cb)
  File "/usr/lib/python2.6/site-packages/yum/", line 1182, in runTransaction
  File "/usr/lib/python2.6/site-packages/yum/", line 580, in futureRpmDBVersion
  File "/usr/lib/python2.6/site-packages/yum/", line 749, in preloadPackageChecksums
    pkg = self.searchNevra(n, e, v, r, a)[0]
IndexError: list index out of range

Running it with -v did not provide any other information regarding this problem. I tried running yum -clean all as well as package-cleanup --dupes and other various forms and rpm -Va --nodeps --nofiledigest but didn't get any output.

I have no idea where to work on that error, so I appreciate any help given.

DrLove73 06-17-2010 12:54 PM

It is important to know what was the last thing you did before this error occurred. Have you installed/updated anything recently? Look in /var/log/yum.log.

Try "yum reinstall yum".

pattbert 06-17-2010 01:06 PM

The last thing I did was an update of my whole system on May 25. The only new things that were installed were a new kernel and mplayer-common.

reinstall yum gives me the same error.

DrLove73 06-17-2010 04:03 PM

I forgot to ask what version you are running now. Please also give us the current kernel number ( "uname -r"), and the output of the "rpm -qa yum python yum-*".

And please can you try running with the older kernel? You can choose it on the boot menu.

Also what comes to mind is to run yum without any plugins: "yum update --disableplugin=*"

If you were able to install yum-utils package, I would suggest runing "yum-complete-transaction" command.

pattbert 06-18-2010 09:14 AM

I'm currently running kernel

Output of rpm -qa yum python yum-*:


Trying to update on two different older kernels still didn't fix the issue and yum-complete-transaction tells me that there are no unfinished transactions.

Thank you for your help so far.

DrLove73 06-19-2010 05:51 AM

Please join Yum mail list ( and present your problem there. I was hopping that someone will jump in, but the best thing is to ask on the yum mailing list, with all the info posted here.

pattbert 06-24-2010 01:41 PM

Updating my system to F13 with preupgrade has fixed the problem. I still have no idea what exactly was going on, but apparently I couldn't even install packages manually with rpm. But now everything's fine again.

All times are GMT -5. The time now is 07:52 AM.