-   Fedora (
-   -   "Yum lock problem" (

PrinceCruise 09-01-2009 12:29 PM

"Yum lock problem"
Hi Folks,

I'm back with a new headache...:o .
Whenever I try to install some package by yum...for an example -
# yum groupinstall "office" - it shows the following message-

"yum is locked by some other application - <app. name>"...
blah blah...

This thing is freaking me I'm not able to use yum for anything.:cry:

looking forward to your valuable suggestions.

Thanks in advance.

John VV 09-01-2009 01:20 PM

have you tried the gui for yum ?? ( add and remove software )

also if yumupdated service is running and you have a mis-configured mirror list . That will cause this

what repos are you using ?

yum repolist

PrinceCruise 09-03-2009 06:06 PM

This is what I've got...

[root@Fedora ~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled: 17
fedora Fedora 11 - i386 enabled: 13,289
updates Fedora 11 - i386 - Updates enabled: 4,958
repolist: 18,264

But I've read in some other threads that killing the other running processes is a solution , but I din't see any other running process...:(

John VV 09-03-2009 07:16 PM

sometimes the "adobe-linux-i386 Adobe Systems Incorporated " repo can lock up and sort of freeze yum.
try turning it off . Like this


su -
( your root password when asked )
gedit /etc/yum.repos.d/adobe-linux-i386.repo

and change this line
-- to --
then try yum again .

chrism01 09-03-2009 11:55 PM


ps -ef|grep yum

if there's a process running

kill <pid>

then check again. If ok, (no yum running) then

yum update

You can also disable the relevant daemon in the Services menu, if you want to always manually ctrl when updates are done.
Look for rhnsd or yum.

PrinceCruise 09-04-2009 08:47 AM

John VV,
Thanks a lot for the valuable suggestion.I'll try that and will update here.

Thanks a lot for your time but I tried this already and that's why i got to know that there was no processes running.Still it's very useful at times so many thanks :) .

mickeyboa 09-09-2009 12:17 PM

I think there is a problem with yum removing when shutting down.
Sometimes when I use Yumex and it acts like it's hanging I click on the "X" top right and shutdown Yumex to restart, you can't get back into Yumex because /var/run/ has not been removed, you physically have to go to /var/run and delete

PTrenholme 09-09-2009 01:29 PM

Folks, Fedora and many other distributions run the PackageManager automatically every time you boot. On Fedora, the PM uses yum.

Since I prefer to do my updates "by hand," I always change the PM setting to never run and never check for updates. If you haven't done this, try using the "Package Manager" application to install the new applications and manage your updates.

(My wife's system, on the other hand, uses the defaults with automatic update and installation so she never needs to "fiddle" with anything. She prefers a system that "just works" and lets her read her e-mail and visit a few Web sites. I only need to touch it every six months or so, when a new Fedora is released.)

chrism01 09-10-2009 01:55 AM

As per #7, check that the file has gone as well. If you killed the process, it may still be there.

mickeyboa 09-10-2009 01:15 PM

I physically removed it from /var/run/

PrinceCruise 09-10-2009 03:35 PM


Thanks a ton...It worked...!!! I have to do it manually :)!!!

Other folks(Senior members/guru),

Seriously appreciate your efforts to make all Linux user's lives easier!!! Thanks a lot!!!

All times are GMT -5. The time now is 03:02 AM.